Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003138 [JEDI VCL] 00 JVCL Components major always 2005-08-07 10:59 2005-08-28 09:10
Reporter xml View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003138: EmbeddedWB and TJvPanel
Description Putting a EmbeddedWB on a JvPanel will not show the (html-)content of the browser.
This only happens under <> XP or XP without manifest-file and only on TForm (not TFrame).
Seems to be something with XP-Theme enabled.
Additional Information Use Delphi 2005 Pro and Arc
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007686)
xml (reporter)
2005-08-07 11:56

You can also use a TWebBrowser instaed of a EmbeddedWB.
(0007755)
obones (administrator)
2005-08-10 01:24

I'm under XP, without any manifest file and I could not reproduce that.
Here is what I did:

Run Delphi 7, Create a new application, Drop a TJvPanel, Drop a TWebBrowser inside, Drop a button, and Add this in its OnClick event:

WebBrowser.Navigate('www.google.com');

This worked just fine.
Could you post a sample application (zipped sources) that displays the behaviour you are talking about?
(0007797)
xml (reporter)
2005-08-15 03:25

I do not use "Navigate". I am loading the html-content from a stream. A "Navigate" to a uri is ok.
(0007799)
obones (administrator)
2005-08-16 01:04

I just tried, no problems whatsoever here with this code:

var
  Stream1 : TFileStream;
begin
  WebBrowser1.Navigate('about:blank');
  Stream1 := TFileStream.Create('E:\prog\jvcl\dev\JVCL3\help\migrating.htm', fmOpenRead);
  try
    (WebBrowser1.Document as IPersistStreamInit).
          Load( TStreamAdapter.Create( Stream1, soOwned ) );
  finally
// Stream1.Free; // Not needed, stream owned by Adapter
  end;

The WebBrowser1 is on a TJvPanel inside a TForm. I'm running on XP without manifest file.

Please post a sample application showing the problem.
(0007870)
obones (administrator)
2005-08-28 09:10

Well, I'm guessing this is resolved. Please open a new issue WITH a sample application using no other third party components than the JVCL should it not be the case.

- Issue History
Date Modified Username Field Change
2005-08-07 10:59 xml New Issue
2005-08-07 11:56 xml Note Added: 0007686
2005-08-10 01:24 obones Note Added: 0007755
2005-08-10 01:24 obones Status new => feedback
2005-08-15 03:25 xml Note Added: 0007797
2005-08-16 01:04 obones Note Added: 0007799
2005-08-28 09:10 obones Status feedback => resolved
2005-08-28 09:10 obones Resolution open => fixed
2005-08-28 09:10 obones Assigned To => obones
2005-08-28 09:10 obones Note Added: 0007870


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker