Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003185 [JEDI VCL] 04 Feature Request minor always 2005-09-08 03:36 2007-12-18 13:41
Reporter Ramengo View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003185: TJvDualListDialog form resize
Description TJvDualListDialog should allow user to resize the form.
If items on the lists are very long or many, then scrolling is difficult.
Splitters would be useful too.
Thanks
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008832)
obones (administrator)
2006-04-03 05:13

Anyone volunteering for this?
(0008841)
jfudickar (developer)
2006-04-03 06:53

Maybe i find some time. But then i also would convert to JvDynControlEngine.
(0008847)
obones (administrator)
2006-04-03 13:05

No problems with me on this conversion. Please do as you see fit.
(0009253)
DRothmaler (reporter)
2006-05-04 02:31

When you are going to rewrite the Component anyway, it would be nice to have to seperate "Sorted" properties for the lists, because I often use this component, but I allway have to patch it to have only one list sorted. Regards Daniel
(0009257)
jfudickar (developer)
2006-05-08 03:05

But how without breaking backword compatibility?
(0009301)
DRothmaler (reporter)
2006-05-15 07:38

Could be done, by two different classes, one with the Properties List1Sorted and List2Sorted; and a derived one with only 1 "Sorted" Property...
Or you could put this "virtual" Sorted property, into the same class, and set it to "stored False". If "List1Sorted and List2Sorted" "Sorted" returns True otherwise Sorted returns False.

This would break the backward compatibility also (because of the new properties), but it would allow a smooth upgrade, without any sourcecode changes.
(0009342)
Ramengo (reporter)
2006-05-23 06:53

I don't know if it may help, but would share this interesting article:
http://bdn.borland.com/article/0,1410,33421,00.html [^]
(0009343)
jfudickar (developer)
2006-05-23 09:27

Maybe it would, but the problem is, no compatibility to d5 - d2005.

So no way in this moment.

For the flow panel there is something similar in TJvPanel, but not the TGridPanel.
(0014087)
AHUser (developer)
2007-12-18 13:40

The dialog now reacts on a resize event if the new property Resizable=True.

- Issue History
Date Modified Username Field Change
2005-09-08 03:36 Ramengo New Issue
2006-04-03 05:13 obones Note Added: 0008832
2006-04-03 05:13 obones Status new => acknowledged
2006-04-03 06:53 jfudickar Note Added: 0008841
2006-04-03 13:05 obones Note Added: 0008847
2006-05-04 02:31 DRothmaler Note Added: 0009253
2006-05-04 02:33 DRothmaler Issue Monitored: DRothmaler
2006-05-06 02:44 DRothmaler Issue End Monitor: DRothmaler
2006-05-06 02:46 DRothmaler Issue Monitored: DRothmaler
2006-05-08 03:05 jfudickar Note Added: 0009257
2006-05-15 07:38 DRothmaler Note Added: 0009301
2006-05-23 06:53 Ramengo Note Added: 0009342
2006-05-23 09:27 jfudickar Note Added: 0009343
2007-12-18 13:40 AHUser Status acknowledged => resolved
2007-12-18 13:40 AHUser Fixed in Version => Daily / SVN
2007-12-18 13:40 AHUser Resolution open => fixed
2007-12-18 13:40 AHUser Assigned To => AHUser
2007-12-18 13:40 AHUser Note Added: 0014087


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker