Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003186 [JEDI VCL] 00 JVCL Components crash always 2005-09-09 05:48 2006-06-27 07:56
Reporter demonek View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003186: AV when adding Variant type variable to JvInspector
Description I'd like to use variable that can keep null value, using Integer gives me 0 by default that is wrong. So I tried Variant, but get AV when executing TJvInspectorVarData.New method like :

with TJvInspectorVarData.New(_InspCat, _value.Definition.Name,
          TypeInfo( Variant ), @(_item_ref.asVariant) ) do
begin
  DisplayName := _value.Definition.A_Label; // <-- AV here

Is there any way to fix it or handle with this problem.
Additional Information
Tags No tags attached.
Attached Files zip file icon variant_2006.04.03_18.32.24.zip [^] (16,391 bytes) 2006-04-03 10:26

- Relationships

-  Notes
(0008833)
obones (administrator)
2006-04-03 05:17

Can you post the zipped sources of a sample application?
(0008843)
demonek (reporter)
2006-04-03 10:29

This is modified sample from jvcl.
(0009690)
obones (administrator)
2006-06-27 07:55

This is "expected" as the New function returns nil.
This is because Variant is not a registered data type in the RegisterDataTypeKinds method.
I have added a new Variant support class into the current SVN version.

- Issue History
Date Modified Username Field Change
2005-09-09 05:48 demonek New Issue
2006-04-03 05:17 obones Note Added: 0008833
2006-04-03 05:17 obones Status new => feedback
2006-04-03 10:26 demonek File Added: variant_2006.04.03_18.32.24.zip
2006-04-03 10:29 demonek Note Added: 0008843
2006-06-08 02:55 obones Status feedback => acknowledged
2006-06-27 07:55 obones Status acknowledged => resolved
2006-06-27 07:55 obones Fixed in Version => Daily / SVN
2006-06-27 07:55 obones Resolution open => fixed
2006-06-27 07:55 obones Assigned To => obones
2006-06-27 07:55 obones Note Added: 0009690


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker