Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003189 [JEDI VCL] 00 JVCL Components minor always 2005-09-10 14:51 2005-11-22 09:24
Reporter devedit View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 RC 1
Summary 0003189: JVDocking loading problem
Description In reality this is probably a problem with my code and not yours but I was hoping I could get some help because it's frustrating me.

The problem I'm having is the docking forms are displaying before they are docked in their appropriate places. I have the following rather simplistic code atm:

  jvAppStorageLS := TJvAppINIFileStorage.Create(self);
  jvAppStorageLS.AutoReload := True;
  JvAppStorageLS.Filename := ExtractFilePath(Application.ExeName) + 'DockInfo.ini';
  CreateDockableForm;
  LoadDockTreeFromAppStorage(jvAppStorageLS);

The CreateDockableForm function just create's the forms that will be docked.

I found for whatever reason if I didn't set the autoreload to true it wouldn't load at all but since none of your examples seem to need that I'm thinking that may be my problem. I'm calling this from the OnCreate function of the main form.

Any thoughts? Thanks
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008047)
muk (reporter)
2005-10-20 21:54

Your CreateDockableForm must create the form with Visible set False, later LoadDockTreeFromAppStorage call handles visibilites.

- Issue History
Date Modified Username Field Change
2005-09-10 14:51 devedit New Issue
2005-10-20 21:54 muk Note Added: 0008047
2005-11-22 09:24 obones Status new => resolved
2005-11-22 09:24 obones Resolution open => fixed
2005-11-22 09:24 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker