Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003192 [JEDI VCL] 00 JVCL Components minor always 2005-09-12 07:22 2005-11-26 04:26
Reporter batonik View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003192: JvCsvData: ProcessCsvHeaderRow(): invalid handling of columns with options ("name:options")
Description When opening a CSV file, procedure InternalInitFieldDefs() is called (in InternalOpen()) which sets up "FieldDefs" list. A field name is extracted from the form "<NAME>[:OPTIONS]" and added to "FieldDefs".
Then, in ProcessCsvHeaderRow() procedure, options are not stripped from column's name so that a call "FCsvColumns.FindByName(...)" returns nil and an exception is raised.
Since "options" in column names are pretty handy (but I found them while reading source files ;) - I've attached a patch :)
Additional Information
Tags No tags attached.
Attached Files ? file icon JvCsvData.patch [^] (880 bytes) 2005-09-12 07:22

- Relationships

-  Notes
(0007927)
batonik (reporter)
2005-09-12 07:28

I've forgotten to say that this patch is for the latest CVS version of JvCsvData.pas - 1.108.
(0008159)
obones (administrator)
2005-11-26 04:26

This is now fixed in CVS. Thanks for the patch, it made my life much easier as the file had evolved a bit in between.

- Issue History
Date Modified Username Field Change
2005-09-12 07:22 batonik New Issue
2005-09-12 07:22 batonik File Added: JvCsvData.patch
2005-09-12 07:28 batonik Note Added: 0007927
2005-11-22 09:32 obones Status new => assigned
2005-11-22 09:32 obones Assigned To => obones
2005-11-26 04:26 obones Status assigned => resolved
2005-11-26 04:26 obones Resolution open => fixed
2005-11-26 04:26 obones Note Added: 0008159


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker