Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003235 [JEDI VCL] 00 JVCL Components crash always 2005-09-26 12:56 2005-09-27 10:46
Reporter ppm View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003235: TJvMemoryData silent crash
Description if Dataset is Active then ClearRecords execute twice - first correctly , second inncorectly from "inhertied Destroy" which calls InternalClose with ClearRecords after FRecords.Free in TJvMemoryData.Destroy
"silent" - because it doesn't generate any exception ussualy (more often in multithreaded application) - sometimes occur EAccessViolation with access invalid address message
Additional Information my patch - simple Close if active

destructor TJvMemoryData.Destroy;
var
  I: Integer;
  PFValues: TPVariant;
begin
  if Active then
    Close;
  if Assigned(FDeletedValues) then
  begin
    if FDeletedValues.Count > 0 then
      for I := 0 to (FDeletedValues.Count - 1) do
      begin
        PFValues := FDeletedValues[I];
        Dispose(PFValues);
      end;
    FreeAndNil(FDeletedValues);
  end;
  FreeIndexList;
  ClearRecords;
  FRecords.Free;
  ReallocMem(FOffsets, 0);
  inherited Destroy;
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007985)
AHUser (developer)
2005-09-27 10:46

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-09-26 12:56 ppm New Issue
2005-09-27 10:46 AHUser Status new => resolved
2005-09-27 10:46 AHUser Resolution open => fixed
2005-09-27 10:46 AHUser Assigned To => AHUser
2005-09-27 10:46 AHUser Note Added: 0007985


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker