Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003237 [JEDI VCL] 00 JVCL Components minor always 2005-09-27 05:27 2005-10-04 14:16
Reporter ydmitrya View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003237: 0001817: Access violation when using SetBitmapPixelFormat
Description When changing BitMapPixelFormat from 32bit to 8bit an access violation occurs in function BitmapToMemoryStream.
This is because variable ImageSize is not adjusted to the new, smaller size of the Bitmap.
Additional Information To make here so:
        if SourceBitmapFormat = pfDevice then
          Result.Write(Bits^, ImageSize)
        else
        if SourceBitmapFormat = pf32bit then
          Result.Write(Bits^, ImageSize div 4)
        else
          Result.Write(Bits^, ImageSize div 3);

Or to alter for all bitmap formats
Tags No tags attached.
Attached Files

- Relationships
related to 0001817resolveduser72 Access violation when using SetBitmapPixelFormat 

-  Notes
(0008001)
remkobonte (developer)
2005-10-04 14:16

This is now fixed in rev. 1.173 of JvJVCLUtils.pas. Thanks for the report.

- Issue History
Date Modified Username Field Change
2005-09-27 05:27 ydmitrya New Issue
2005-09-27 14:37 remkobonte Relationship added related to 0001817
2005-10-01 05:49 remkobonte Status new => assigned
2005-10-01 05:49 remkobonte Assigned To => remkobonte
2005-10-04 14:16 remkobonte Status assigned => resolved
2005-10-04 14:16 remkobonte Resolution open => fixed
2005-10-04 14:16 remkobonte Note Added: 0008001


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker