Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003272 [JEDI VCL] 00 JVCL Components major always 2005-10-17 13:26 2006-01-08 12:26
Reporter IOn View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003272: TJvThumbImage.SaveToFile --> save to JPEG
Description When running TJvThumbImage.SaveToFile and AFile is a JPEG an error is encountered
Additional Information Sollution

Change in run\JvThumbImage.pas
....
if (Ext = '.JPG') or (Ext = '.JPEG') then
    try
      Jpg := TJpegImage.Create;
      Jpg.Assign(Picture);
      Jpg.CompressionQuality := 75;
      Jpg.Compress;
      Jpg.SaveToFile(AFile);
....

to

....
if (Ext = '.JPG') or (Ext = '.JPEG') then
    try
      Jpg := TJpegImage.Create;
      Jpg.Assign(Picture.Graphic);
      Jpg.CompressionQuality := 75;
      Jpg.Compress;
      Jpg.SaveToFile(AFile);
....
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008350)
obones (administrator)
2006-01-08 12:26

This has been fixed since at least February 2005, please update your version of the JVCL.

- Issue History
Date Modified Username Field Change
2005-10-17 13:26 IOn New Issue
2006-01-08 12:26 obones Status new => resolved
2006-01-08 12:26 obones Resolution open => fixed
2006-01-08 12:26 obones Assigned To => obones
2006-01-08 12:26 obones Note Added: 0008350


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker