Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003298 [JEDI VCL] 00 JVCL Components major always 2005-11-02 22:52 2005-11-22 09:08
Reporter ZENsan View Status public  
Assigned To elahn
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003298: FormStorage component don't save TEdit.Text value if it's containing only one space!
Description FormStorage component don't save TEdit.Text value if it's containing only one space! Why??? I need to write code to save this value, because space also is an string data!!!
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008075)
elahn (developer)
2005-11-03 02:32

If you are using TJvAppIniFileStorage, set StorageOptions to include PreserveLeadingTrailingBlanks. You will receive an AV the first time you run the program and it tries to restore an empty string property...just ignore this and when you close the program it will save correctly.

If this does not fix the problem, please post an example program that produces the problem - zipped, including .dpr, .pas & .dfm only.
(0008130)
obones (administrator)
2005-11-22 09:08

This is considered to be resolved for it has not received any feeback for the past 14 days.

- Issue History
Date Modified Username Field Change
2005-11-02 22:52 ZENsan New Issue
2005-11-03 02:32 elahn Note Added: 0008075
2005-11-03 02:32 elahn Assigned To => elahn
2005-11-03 02:32 elahn Status new => feedback
2005-11-22 09:08 obones Status feedback => resolved
2005-11-22 09:08 obones Resolution open => fixed
2005-11-22 09:08 obones Note Added: 0008130


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker