Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003299 [JEDI VCL] 00 JVCL Components minor always 2005-11-03 12:19 2006-04-05 01:23
Reporter dsiders View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003299: TJvMarkupViewer.ParseHtml error in nested ParseTag
Description The parse tag procedure in TJvMarkupViewer.ParseHtml contains an error.

  // handle LTag
  LTag := LowerCase(LTag);
  ...
  if LTag = 'I' then
  begin // italic
    PushTag;
    FStyle := FStyle + [fsItalic];
  end
  else
  if LTag = '/I' then
  begin // cancel italic
    FStyle := FStyle - [fsItalic];
    PopTag;
  end
  ...

As you can see, neither nor tagsd are handled properly because the value in the comparision is uppercase while the tag is lowercase.
Additional Information Line 321 in JvMarkupViewer.pas
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008867)
obones (administrator)
2006-04-04 05:09

Thanks, this is now ready to be commited to CVS as soon as it is back online.
(0008944)
obones (administrator)
2006-04-05 01:23

This is now in CVS

- Issue History
Date Modified Username Field Change
2005-11-03 12:19 dsiders New Issue
2006-04-04 05:09 obones Note Added: 0008867
2006-04-04 05:09 obones Status new => confirmed
2006-04-05 01:23 obones Status confirmed => resolved
2006-04-05 01:23 obones Resolution open => fixed
2006-04-05 01:23 obones Assigned To => obones
2006-04-05 01:23 obones Note Added: 0008944


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker