Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003317 [JEDI VCL] 00 JVCL Components major always 2005-11-18 10:45 2006-04-05 06:56
Reporter marcgeldon View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003317: TJvDBGrid - AutoAppend does not fully work
Description if you have a dataset with no records in it (RecordCount = 0, for example an empty table) and you want to change field values in the TJvDBGrid and AutoAppend = True, then a new data record is created.

It is not possible to insert or append data records if the RecordCount is > 0.

I'll add a workaround, but I think this problem should be fixed on the component.
Additional Information My workaround is the following:
procedure TForm1.JvDBGridShowEditor(Sender: TObject;
  Field: TField; var AllowEdit: Boolean);
begin
  AllowEdit := (TJvDBGrid(Sender).DataSource.DataSet.RecordCount > 0);
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008210)
marcgeldon (reporter)
2005-12-12 15:28

Bug which is very easy to change. Can someone change that stuff in CVS?
(0008549)
Informatix (developer)
2006-02-14 05:59

What bug ? I tested today and all works fine. You use probably a very old version of JVCL.

Fred
(0008972)
obones (administrator)
2006-04-05 06:31

marc, does this still happen with the latest version of the JVCL?
(0008984)
marcgeldon (reporter)
2006-04-05 06:52

You can close this bug. I cannot reproduce the "bug" (?) anymore.
(0008989)
obones (administrator)
2006-04-05 06:56

Thanks marc for letting us know.

- Issue History
Date Modified Username Field Change
2005-11-18 10:45 marcgeldon New Issue
2005-12-12 15:28 marcgeldon Note Added: 0008210
2006-02-14 05:59 Informatix Note Added: 0008549
2006-04-05 06:31 obones Note Added: 0008972
2006-04-05 06:31 obones Status new => feedback
2006-04-05 06:52 marcgeldon Note Added: 0008984
2006-04-05 06:56 obones Status feedback => resolved
2006-04-05 06:56 obones Resolution open => fixed
2006-04-05 06:56 obones Assigned To => obones
2006-04-05 06:56 obones Note Added: 0008989


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker