Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003321 [JEDI VCL] 00 JVCL Components tweak always 2005-11-20 04:46 2005-12-29 22:27
Reporter Betalord View Status public  
Assigned To elahn
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003321: TJvDesktopAlert gives focus to app
Description TJvDesktopAlert gives focus to parent application once it disappears. This can be very annoying. AutoFocus property doesn't seem to have effect on it.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008142)
obones (administrator)
2005-11-22 09:22

Use the daily snapshots from here:

http://jvcl.sf.net/daily/ [^]

And tell us if that still happens.
(0008167)
Betalord (reporter)
2005-11-26 06:28

With the latest snapshot (26.11.05) application does not receive "visual" focus (aplication title window doesn't become blue and application's form doesn't come on top of other applications), but Application.OnActivate is till triggered and Application.Active is set to true, so this problem is not yet solved.
(0008190)
elahn (developer)
2005-12-02 18:13

This is now fixed in CVS.

It came from the call "Windows.SetParent(Handle, 0);" in TJvFormDesktopAlert.ShowNoActivate, which was introduced to partially solve the issue of the visible TJvFormDesktopAlert(s) dropping behind another App when this App is defocused.
(0008253)
Betalord (reporter)
2005-12-29 10:48

Is there any good reason why this fix hasn't been included with 3.10 JVCL release? It has been fixed on 12-02-05, 3.10 has been released on 12-13-05 (11 days later). Will it be included with next release?
(0008254)
elahn (developer)
2005-12-29 22:27

The 3.10 release was made on the 31st of October to be included in the Partner DVD of BDS 2006. This release does NOT contain changes made in the CVS since the 31st of October. We are planning a complete release in a few weeks time.

- Issue History
Date Modified Username Field Change
2005-11-20 04:46 Betalord New Issue
2005-11-22 09:22 obones Note Added: 0008142
2005-11-22 09:22 obones Status new => feedback
2005-11-26 06:28 Betalord Note Added: 0008167
2005-12-02 18:13 elahn Status feedback => resolved
2005-12-02 18:13 elahn Resolution open => fixed
2005-12-02 18:13 elahn Assigned To => elahn
2005-12-02 18:13 elahn Note Added: 0008190
2005-12-29 10:48 Betalord Status resolved => feedback
2005-12-29 10:48 Betalord Resolution fixed => reopened
2005-12-29 10:48 Betalord Note Added: 0008253
2005-12-29 22:27 elahn Status feedback => resolved
2005-12-29 22:27 elahn Resolution reopened => fixed
2005-12-29 22:27 elahn Note Added: 0008254


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker