Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003326 [JEDI VCL] 00 JVCL Components major always 2005-11-24 15:27 2005-11-26 05:12
Reporter marcgeldon View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003326: TJvTranslator - EAccessViolation
Description put a TJvTranslator on a form, but 2 buttons on a form. In the "OnClick" procedure from one button call the TJvTranslator procedure "ComponentToXML" for the other button. You'll get an EAccessViolation.
Additional Information Have a look at the small demo application (attached here) and press on the button "Click here".
Tags No tags attached.
Attached Files zip file icon demo.zip [^] (1,071 bytes) 2005-11-24 15:27

- Relationships

-  Notes
(0008163)
obones (administrator)
2005-11-26 05:06

Just seen this under D6 with the given demo
(0008164)
obones (administrator)
2005-11-26 05:12

This is now fixed in CVS. The exception did not surface to the application because it was ignored (empty except section), but there was an easy way to avoid any exception at all. This is what is in CVS.

- Issue History
Date Modified Username Field Change
2005-11-24 15:27 marcgeldon New Issue
2005-11-24 15:27 marcgeldon File Added: demo.zip
2005-11-26 05:06 obones Note Added: 0008163
2005-11-26 05:06 obones Status new => confirmed
2005-11-26 05:12 obones Status confirmed => resolved
2005-11-26 05:12 obones Resolution open => fixed
2005-11-26 05:12 obones Assigned To => obones
2005-11-26 05:12 obones Note Added: 0008164


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker