Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003338 [JEDI VCL] 00 JVCL Components minor always 2005-12-03 01:46 2006-05-09 04:50
Reporter SVitaliy View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003338: Method CloseThreadDialogForm of JvThreadAnimateDialog didn’t work.
Description In code that I upload method CloseThreadDialogForm, doesn’t work.

I think that usage of this method is right.
Additional Information
Tags No tags attached.
Attached Files ? file icon Backup.pas [^] (2,920 bytes) 2005-12-03 01:46
? file icon Backup.dfm [^] (4,513 bytes) 2005-12-11 01:49
rar file icon TJvThreadAnimateDialog.rar [^] (3,382 bytes) 2006-04-09 02:33
rar file icon TJvThreadAnimateDialog_1.rar [^] (2,398 bytes) 2006-04-12 01:34

- Relationships

-  Notes
(0008201)
jfudickar (developer)
2005-12-10 12:34

Why did you want to call the CloseThreadDialogForm??

Normaly this is not necessary.

Please give me some more infos. And if possible also attach the dfm-file.

Please also have a look at the examples\jvthread sample application.

Greetings
Jens
(0008203)
SVitaliy (reporter)
2005-12-11 02:07

I am aware that automatically hide of JvThreadAnimateDialog occur after thread stop.

I hide my own form when event “Thread Begin” occurs. And I show my own form when event “Thread Finish” occurs.

When event “Thread Finish” occurs the JvThreadAnimateDialog is still visible. I think that calling of CloseThreadDialogForm can hide it forcibly.
(0008205)
jfudickar (developer)
2005-12-11 12:25

Please try to "Synchronize" the CloseThreadDialogForm call.

This could be a problem of thread handling.

Greetings
Jens
(0008206)
SVitaliy (reporter)
2005-12-12 06:28

I try synchronizing via next code:

procedure TBackup_Form.JvThreadFinish(Sender: TObject);
begin
 Synchronize(HideDlg);
 If FNoErr
  then InfoMessage('')
  else ErrorMessage(FErr);
 Show;
end;

procedure TBackup_Form.HideDlg(Sender: TObject);
begin
 JvThreadAnimateDialog.CloseThreadDialogForm
end;

But this has no effect.

Will very good, if you will offer something best.

Cheers
Vitaliy
(0008879)
obones (administrator)
2006-04-04 05:58

Any news here?
If possible, please provide the complete zipped sources of a sample application.
(0009044)
SVitaliy (reporter)
2006-04-09 02:35
edited on: 2006-04-09 02:37

I upload complete sample in TJvThreadAnimateDialog.rar.

Remark. Database path, login, password must be configured.

(0009048)
jfudickar (developer)
2006-04-09 05:51

Sorry, could you modify the sample a little bit.

Please use english labels and give me a small help. I didn't have the uib components, so what is the usage of your sample.
(0009058)
SVitaliy (reporter)
2006-04-09 15:51

UIB components is part of JVCL!?

Some help and english labels, Ok may be tomorrow.
(0009071)
SVitaliy (reporter)
2006-04-12 01:38

Algorithm

Main Program
1 Start thread
-------------
Thread
Event On Start: Hide MainForm
Event On Finish: Execution result message (could not be part of Execute Method)
-------------
Error: Event on Finish occur but Thread Status still visible.
(0009144)
jfudickar (developer)
2006-04-19 13:23

Hi,

thanks for the update sample.

Now i understand your problem :-)

I've removed the procedure, because it could not work, it's impossible if the form is modal.

But the good news is : i've changed the code and now the form is automaticly hidden before you show the messagebox.

I've uploaded my changes to svn.

Greetings
Jens
(0009170)
SVitaliy (reporter)
2006-04-23 03:00

What is svn?
(0009173)
jfudickar (developer)
2006-04-23 10:14

It's the followup of cvs.

Have a look at http://homepages.borland.com/jedi/wiki/index.php?title=Repository [^]
(0009259)
jfudickar (developer)
2006-05-08 12:37

Did you have tested it ?
(0009263)
SVitaliy (reporter)
2006-05-09 04:24

I am sorry; I forgot to write an answer.

Current version of ThreadDialog work properly.


Thank You.

- Issue History
Date Modified Username Field Change
2005-12-03 01:46 SVitaliy New Issue
2005-12-03 01:46 SVitaliy File Added: Backup.pas
2005-12-06 09:36 jfudickar Status new => assigned
2005-12-06 09:36 jfudickar Assigned To => jfudickar
2005-12-10 12:34 jfudickar Note Added: 0008201
2005-12-10 12:34 jfudickar Status assigned => feedback
2005-12-11 01:49 SVitaliy File Added: Backup.dfm
2005-12-11 02:07 SVitaliy Note Added: 0008203
2005-12-11 12:25 jfudickar Note Added: 0008205
2005-12-12 06:28 SVitaliy Note Added: 0008206
2006-04-04 05:58 obones Note Added: 0008879
2006-04-09 02:33 SVitaliy File Added: TJvThreadAnimateDialog.rar
2006-04-09 02:35 SVitaliy Note Added: 0009044
2006-04-09 02:37 SVitaliy Note Edited: 0009044
2006-04-09 05:51 jfudickar Note Added: 0009048
2006-04-09 15:51 SVitaliy Note Added: 0009058
2006-04-12 01:08 obones Status feedback => acknowledged
2006-04-12 01:34 SVitaliy File Added: TJvThreadAnimateDialog_1.rar
2006-04-12 01:38 SVitaliy Note Added: 0009071
2006-04-19 13:23 jfudickar Note Added: 0009144
2006-04-19 13:23 jfudickar Status acknowledged => feedback
2006-04-23 03:00 SVitaliy Note Added: 0009170
2006-04-23 10:14 jfudickar Note Added: 0009173
2006-05-08 12:37 jfudickar Note Added: 0009259
2006-05-09 04:24 SVitaliy Note Added: 0009263
2006-05-09 04:49 jfudickar Status feedback => resolved
2006-05-09 04:49 jfudickar Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker