Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003357 [JEDI VCL] 00 JVCL Components minor always 2005-12-11 11:49 2006-01-08 08:52
Reporter tomki View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003357: JvDatePickerEdit does not always appear right underneath the input control
Description The first time, the dropdown dialog is been called, the calendar appears exactly where it is supposed to appear - i.e. underneath the edit input control.
If subsequently the main form is moved on the desktop, and the dropdown dialog called again, the calendar again appears at its previous position. This happens some times - until suddenly - for no reproducible reason - it appears right underneath the input control again.
Please have a look at the attached screenshots (sortet by time). The subject test program is also attached in the zip-file. It doesn’t contain any code - just the JvDatePickerEdit as the only component on the main form - that’s it.
Additional Information I'm using Delhpi 2005 + WinXP
Tags No tags attached.
Attached Files zip file icon datepick.zip [^] (334,705 bytes) 2005-12-11 11:49

- Relationships
has duplicate 0003440resolvedobones JvDBDatePicker don't change it's popup position when owner form is moved!! 

-  Notes
(0008333)
obones (administrator)
2006-01-08 08:40

I'm seing this with Delphi 6 as well, under WinXP.
(0008334)
obones (administrator)
2006-01-08 08:52

This is now solved in CVS. Basically, the popup was only repositionned when it got created. And the TJvDatePickerEdit component does not recreate its calendar everytime it is shown.

- Issue History
Date Modified Username Field Change
2005-12-11 11:49 tomki New Issue
2005-12-11 11:49 tomki File Added: datepick.zip
2005-12-14 01:44 tomki Issue Monitored: tomki
2006-01-08 08:40 obones Note Added: 0008333
2006-01-08 08:40 obones Status new => confirmed
2006-01-08 08:52 obones Status confirmed => resolved
2006-01-08 08:52 obones Resolution open => fixed
2006-01-08 08:52 obones Assigned To => obones
2006-01-08 08:52 obones Note Added: 0008334
2006-01-13 08:51 obones Relationship added has duplicate 0003440
2006-03-05 10:49 obones Relationship added duplicate of 0003551
2006-03-05 10:50 obones Relationship deleted 0003551


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker