Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003384 [JEDI VCL] 00 JVCL Components major always 2005-12-26 03:18 2006-03-10 02:15
Reporter WBenner View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003384: Installation of JVCL for Delphi 2005
Description I have installed Delphi 7 AND Delphi 2005. I can install JCL without problems. The jediinstaller recognizes both Delphi platforms. The Installer of JVCL recognizes only Delphi 7.
Any Ideas?
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0003467resolvedAHUser Install fails when JCL installed in non-standart path (with decision) 

-  Notes
(0008280)
obones (administrator)
2006-01-05 07:53

What message?
(0008307)
WBenner (reporter)
2006-01-06 02:32

There are no error messages. The jediinstaller.exe for JVCL recognizes only Delhi 7. The Jediinstaller for the JCL recognizes both platforms. Very mysterious.
(0008309)
ivan_ra (developer)
2006-01-06 04:43
edited on: 2006-01-06 04:45

The same problem (jvcl 3.1).
May be because JCL packages installed in non standart path:
c:\borland\bds\3.0\projects\bpl
c:\borland\bds\4.0\projects\bpl

there is no problems for jvcl 3.0 + Delphi2005 + the same path

(0008480)
WBenner (reporter)
2006-02-01 01:56

The last installation from 30.1.2006 has the same problems like before. The JCL is installed for both platforms, the JVCL only for Delphi 7. There are no error messages.
What have you changed in your fix?
(0008482)
AHUser (developer)
2006-02-01 02:31

- IsDelphi and IsBCB are now private and should not be used anymore.
IsDelphi is only set if it's not a BDS, IsBCB is only set if it's not a
BDS.
- There's a new methode SupportsPersonalities([persDelphi, persBCB,
persCSharp, persDelphiNet])
- Default paths for BDS have changed:
  HppDir: $(BDS)\Include\JVCL => GlobalIncludePaths list
  DcpDir: $(JVCL)\Lib\$(VER)
- UnitOutDir + Resources is added to C++'s global search path
- Include directory is created if not existant (only if persBCB is
supported/installed)
- BDSProjectsDir is now read from the IDE's environment variable if set
- Support for user defined BPL/DCP directory is improved.
- BDS's package cache and palette cache is cleared
- JCL detection is improved, all PATH entries are searched for the JCL bpl
files.
- Directory-Edits do no more show the dir-browse dialog if the user enters
or single clicks the edit control.
- Compile dialog is brought to front without stealing the focus.

I haven't tested the updated installer with BCB 5/6, BDS 3.0 (D2005).
(0008483)
AHUser (developer)
2006-02-01 03:47

> The jediinstaller.exe for JVCL recognizes only Delhi 7

What do you exactly mean with "recognizes"? Does it show a disabled "Borland Developer Studio 2006" checkbox, or doesn't it show this checkbox at all?


There is no JediInstaller.exe for JVCL :-)
(0008488)
WBenner (reporter)
2006-02-01 11:19

Sorry, i mean jvclinstall.exe of course and my second delphi platform is 2005.
I have debugged the source of jvclinstall.exe and have detected the problem. The program has not found djcl90.bpl for Delphi 2005, which was in another directory. After copy in a common bpl-directory was delhi 2005 recognized.

Now i can build JCL and JVCL for both platforms, but in 2005 is still a problem with loading jvcl*.bpl files. Delphi 2005 means that package djcl90 cannot loaded because unit zlibh is defined in package jcl90 :-(

I think, that Delphi 2005 has trouble with the different directories for jedi in DELPHI7/JEDI and PROGRAMME/BORLAND/BDS/3.0/KOMPONENTEN/JEDI and two bpl directories which are all in path.
(0008582)
AHUser (developer)
2006-02-21 04:40

> djcl90 cannot loaded because unit zlibh is defined in
> package jcl90

That means you have an older JCL and a new JCL installed at the same time. The JCL has changed the package naming from DJclXX.bpl to JclXX.bpl (without the leading "D").
(0008640)
AHUser (developer)
2006-03-10 02:15

No response for more than a week.

- Issue History
Date Modified Username Field Change
2005-12-26 03:18 WBenner New Issue
2006-01-05 07:53 obones Note Added: 0008280
2006-01-05 07:53 obones Status new => feedback
2006-01-06 02:32 WBenner Note Added: 0008307
2006-01-06 04:43 ivan_ra Note Added: 0008309
2006-01-06 04:45 ivan_ra Note Edited: 0008309
2006-01-26 06:04 obones Relationship added related to 0003467
2006-01-26 11:48 AHUser Status feedback => resolved
2006-01-26 11:48 AHUser Resolution open => fixed
2006-01-26 11:48 AHUser Assigned To => AHUser
2006-02-01 01:56 WBenner Status resolved => feedback
2006-02-01 01:56 WBenner Resolution fixed => reopened
2006-02-01 01:56 WBenner Note Added: 0008480
2006-02-01 02:31 AHUser Note Added: 0008482
2006-02-01 03:47 AHUser Note Added: 0008483
2006-02-01 11:19 WBenner Note Added: 0008488
2006-02-02 13:34 flaviomedeiros Issue Monitored: flaviomedeiros
2006-02-21 04:40 AHUser Note Added: 0008582
2006-03-10 02:15 AHUser Status feedback => resolved
2006-03-10 02:15 AHUser Resolution reopened => fixed
2006-03-10 02:15 AHUser Note Added: 0008640


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker