Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003391 [JEDI VCL] 00 JVCL Components major always 2005-12-27 13:11 2006-06-27 06:49
Reporter moore View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003391: edits are lost in db incpestor if not defocusing item, bug or normal behaviour?
Description to reproduce open InspectorDBExample:
focus a field (item) in inspector (last name ex),
change the value of that field,
now click with the mouse in another record in the grid, the changes are lost, when you return the the previously edited record,

the change in value does not put dataset in edit mode, only focusing another field in inspector then dataset is put in edit mode

is it normal behaviour or bug? i think it will be very annoying to make user change the focus from an item to another to make changes, user normally changes the value and skips to other tasks..
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0003522resolvedobones JvInspector's OnItemEdit CONNOT change data Value! 

-  Notes
(0008259)
moore (reporter)
2005-12-31 09:53

I think this because Jvinspector Valuechange is not triggered on exit from the control, i tried to add elements manually without linking to dataset and use valuechange (or changing) but the same problem..
(0008884)
obones (administrator)
2006-04-04 06:10

Can you try with the latest JVCL?
(0009349)
moore (reporter)
2006-05-25 03:34

Same problem with latest JVCL (24/05/06)
(0009680)
obones (administrator)
2006-06-27 06:34

Seing this with today's build, investigating
(0009681)
obones (administrator)
2006-06-27 06:49

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2005-12-27 13:11 moore New Issue
2005-12-27 13:13 moore Issue Monitored: moore
2005-12-27 13:14 moore Issue End Monitor: moore
2005-12-31 09:53 moore Note Added: 0008259
2006-04-04 06:10 obones Note Added: 0008884
2006-04-04 06:10 obones Status new => feedback
2006-04-05 06:49 obones Relationship added related to 0003522
2006-05-25 03:34 moore Note Added: 0009349
2006-06-27 06:34 obones Note Added: 0009680
2006-06-27 06:34 obones Status feedback => confirmed
2006-06-27 06:49 obones Status confirmed => resolved
2006-06-27 06:49 obones Fixed in Version => Daily / SVN
2006-06-27 06:49 obones Resolution open => fixed
2006-06-27 06:49 obones Assigned To => obones
2006-06-27 06:49 obones Note Added: 0009681


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker