Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003406 [JEDI VCL] JclStrings minor always 2006-01-02 17:12 2006-01-17 13:33
Reporter mjwallin View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Version 1.96
Summary 0003406: Functions 'substr' and 'addslash2' missing from jvjclUtils.pas
Description The functions 'substr' and addslash2 are no longer included in jvjclUtils but are available in the archive folder in units jvStrUtil and jvUtils. In the 3.0 library, the substr and addSlash2 functions were in ..\run\JVJCLUTILS.PAS. Both of these functions are called in the JvInterpreter example project jvInterpreterTest. If these functions were eliminated by design, the example project needs to be updated to use replacement functions.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008399)
obones (administrator)
2006-01-17 13:33

AddSlash2 is replaced by PathAddSeparator from JclFileUtils.pas
Substr is replaced by a use of StrToStrings

The example has been fixed in CVS.

- Issue History
Date Modified Username Field Change
2006-01-02 17:12 mjwallin New Issue
2006-01-15 04:57 outchy Project JEDI Code Library => JEDI VCL
2006-01-17 13:33 obones Status new => resolved
2006-01-17 13:33 obones Resolution open => fixed
2006-01-17 13:33 obones Assigned To => obones
2006-01-17 13:33 obones Note Added: 0008399


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker