Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003429 [JEDI VCL] 00 JVCL Components major always 2006-01-09 04:17 2006-04-12 01:17
Reporter Raid View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003429: TJvPageListTreeView does not work with AutoExpand, and does not show RowSelect when running.
Description At runtime, it does not show row select, and does not Auto-Expand.
As well, it doesn't keep the links, and doesn't keep the settings (from design time to runtime) (Settings tested: Lines (shows in design time not at runtime) )
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0002501closed Error with links TjvPageListTreeView <-> TjvStandardPage 

-  Notes
(0008896)
obones (administrator)
2006-04-04 07:18

For the row select and auto expand, please provide a sample application showing in which way it does not work.
For the rest, please refer to issue 0002501.
(0008950)
Raid (reporter)
2006-04-05 01:34

Obones! Hey! Sorry about the lack of participation lately, I've been so busy. T-T .. About the rowselect, I actually traced it down to the 'showlines' property which I posted about a different time with the fix. But the Autoexpand, I actually forgot! It's been awhile, I'll check it out again and see, I'll get back to you shortly with how it errors, and sample. But most likely if I go through that trouble, I'll probably just hunt down the bug for you and fix it lol.. Anyway, I'll post again in a bit, thanks obones!
(0009038)
Raid (reporter)
2006-04-07 15:52

Oookay, I finally got some time to build a testing app and test away, and well after the fix and such. About the AutoExpand I *cannot* reproduce that error so you don't have to worry about it. Also once again the RowSelect was just due to the faulty ShowLines property, so this issue is as good as solved.

^_^
(0009069)
obones (administrator)
2006-04-12 01:17

Ok, then this is marked as fixed.

- Issue History
Date Modified Username Field Change
2006-01-09 04:17 Raid New Issue
2006-04-04 07:17 obones Relationship added related to 0002501
2006-04-04 07:18 obones Note Added: 0008896
2006-04-04 07:18 obones Status new => feedback
2006-04-05 01:34 Raid Note Added: 0008950
2006-04-07 15:52 Raid Note Added: 0009038
2006-04-12 01:17 obones Status feedback => resolved
2006-04-12 01:17 obones Resolution open => fixed
2006-04-12 01:17 obones Assigned To => obones
2006-04-12 01:17 obones Note Added: 0009069


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker