Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003457 [JEDI VCL] 00 JVCL Components minor always 2006-01-19 22:55 2006-01-22 02:01
Reporter dejoy View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003457: About function InstallProcHook in JvVCL5Utils.pas
Description I found the function of InstallProcHook is a very nice idea,but it's only in JvVCL5Utils.pas,thus can't used in up delphi5. so can be move to the common unit pas? such as JvJclUtils.pas?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008409)
AHUser (developer)
2006-01-20 05:44
edited on: 2006-01-20 05:46

InstallProcHook is not for general purpose usage. It is very unstable and works only in rare cases because it was specially written for some Delphi 5 functions where it works.
If you want a "works for all functions" hook you should have a look at Madshi's CodeHook library:
[url]http://www.madshi.net/madCodeHookDescription.htm[/url] [^]

(0008416)
dejoy (reporter)
2006-01-21 00:28

Thanks!

- Issue History
Date Modified Username Field Change
2006-01-19 22:55 dejoy New Issue
2006-01-20 05:44 AHUser Note Added: 0008409
2006-01-20 05:44 AHUser Status new => feedback
2006-01-20 05:46 AHUser Note Edited: 0008409
2006-01-21 00:28 dejoy Note Added: 0008416
2006-01-22 02:00 AHUser Issue Monitored: AHUser
2006-01-22 02:01 AHUser Status feedback => resolved
2006-01-22 02:01 AHUser Resolution open => fixed
2006-01-22 02:01 AHUser Assigned To => AHUser
2007-12-16 11:19 AHUser Issue End Monitor: AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker