Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003462 [JEDI VCL] 00 JVCL Components major always 2006-01-23 13:01 2006-01-23 17:33
Reporter vrtareg View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003462: ReplaceAllStrings function Error
Description Function ReplaceAllStrings in run\JvJCLUtils.pas and in qrun\JvQJCLUtils.pas return the same input string value due function code error.

Old incorrect code
------------------------------------------------------------
  for I := 0 to Words.Count - 1 do
    Result := ReplaceString(S, Words[I], Frases[I]);
  Result := S;
------------------------------------------------------------

New corrected code
------------------------------------------------------------
  Result:= S;
  for I:= 0 to Words.Count - 1 do
    Result:= ReplaceString(Result, Words[I], Frases[I]);
------------------------------------------------------------

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008432)
AHUser (developer)
2006-01-23 17:33

Fixed in CVS.

I have not changed the code in qrun\JvQJCLUtils.pas because these files are autogenerated.

- Issue History
Date Modified Username Field Change
2006-01-23 13:01 vrtareg New Issue
2006-01-23 17:33 AHUser Status new => resolved
2006-01-23 17:33 AHUser Resolution open => fixed
2006-01-23 17:33 AHUser Assigned To => AHUser
2006-01-23 17:33 AHUser Note Added: 0008432


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker