Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003485 [JEDI VCL] 00 JVCL Components crash always 2006-02-01 04:49 2006-02-01 07:48
Reporter Grant Brown View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003485: bug in installer
Description when trying to run install.bat which results in an attempt to compile the installer on a clean version of delphi 5 the compile of the installer fails.

This is due to the DelphiData.pas not being able to find function : AnsiContainsText

(which is contained in unit ..\\ITEStrip\isuUtils.pas(13):

This AnsiContainsText is called in function IsDelphi and the function directly previous to this.
Additional Information The work around for me was to copy the AnsiContainsText function from isuUtils.pas into DelphiData.pas, save the pas file and then re-run install.bat which then compiles the installer in a proper manner.

HTH

Regards
Grant Brown
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008484)
AHUser (developer)
2006-02-01 07:48

Please use a daily snapshot of JCL and JVCL. The JVCL 3.10 was exclusivly released for BDS 2006 and was not tested against older Delphi/BCB versions. This is already fixed in the daily snapshots.

http://jcl.sf.net/daily [^]
http://jvcl.sf.net/daily [^]

- Issue History
Date Modified Username Field Change
2006-02-01 04:49 Grant Brown New Issue
2006-02-01 07:48 AHUser Status new => resolved
2006-02-01 07:48 AHUser Resolution open => fixed
2006-02-01 07:48 AHUser Assigned To => AHUser
2006-02-01 07:48 AHUser Note Added: 0008484


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker