Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003515 [JEDI VCL] 04 Feature Request feature always 2006-02-15 06:07 2006-03-10 03:03
Reporter Ramengo View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003515: JvDirectoryListBox multi selection
Description It would be useful if JvDirectoryListBox had the property MultiSelect like JvFileListBox. The Selected property could then be looped to list the directory selected.
Thanks in advance !
Additional Information
Tags No tags attached.
Attached Files zip file icon 3515.zip [^] (4,587 bytes) 2006-02-16 17:58

- Relationships

-  Notes
(0008567)
Samuel Herzog (reporter)
2006-02-16 18:02

Add the statement

      property MultiSelect;

to the published section of class TJvDirectoryListBox.

Maybe it would also be confortable to set "AutoExpand"=false when "MultiSelect" is set to true.

This works fine. I have addded the demo project.
Since I have no access to the source control I would be glad if someone else could add this change to the sources.
(0008577)
Ramengo (reporter)
2006-02-20 07:38

Thanks Samuel
(0008633)
Ramengo (reporter)
2006-03-08 06:55

Please, someone with right privileges could update the CVS ?
(0008646)
AHUser (developer)
2006-03-10 03:03

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2006-02-15 06:07 Ramengo New Issue
2006-02-16 17:58 Samuel Herzog File Added: 3515.zip
2006-02-16 18:02 Samuel Herzog Note Added: 0008567
2006-02-20 07:38 Ramengo Note Added: 0008577
2006-03-08 06:55 Ramengo Note Added: 0008633
2006-03-10 03:03 AHUser Status new => resolved
2006-03-10 03:03 AHUser Resolution open => fixed
2006-03-10 03:03 AHUser Assigned To => AHUser
2006-03-10 03:03 AHUser Note Added: 0008646


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker