Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003526 [JEDI VCL] 00 JVCL Components crash always 2006-02-20 15:51 2006-02-21 09:26
Reporter denisfitz View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003526: JVCL install fails
Description the following is the output from the install:

build.exe found. Pretest: ok
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
[Generating MO files]
[Compiling: Installer]
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
Writing: ..\..\install\JVCLInstall\JVCLInstall.cfg
Borland Delphi for Win32 compiler version 18.0
Copyright (c) 1983,2005 Borland Software Corporation

C:\JVCL32006\run\JvExControls.pas(996) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExControls.pas(1197) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExControls.pas(1532) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExControls.pas(1733) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExControls.pas(2068) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(1435) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(1636) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(1837) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(2038) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(2239) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(2574) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(2909) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(3244) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(3579) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(3914) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(4249) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(4584) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(4919) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExExtCtrls.pas(6799) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(768) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(1103) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(1438) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(1773) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(2108) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(2443) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(2802) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExForms.pas(3162) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(1377) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(1714) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(1915) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(2119) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(2485) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(3187) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(3522) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(3857) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(4192) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(4527) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(4862) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(5197) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(5532) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(5867) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(6202) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExStdCtrls.pas(6537) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(3549) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(3884) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(4219) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(4554) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(4889) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(5224) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(5559) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(5894) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(6229) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(6564) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(6899) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(7234) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(7569) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(7904) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(8239) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(8574) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(8909) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(9244) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(9579) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(9914) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(10249) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(10584) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(10919) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvExComCtrls.pas(11254) Hint: H2443 Inline function 'PointToSmallPoint' has not been expanded because unit 'Types' is not specified in USES list

C:\JVCL32006\run\JvWizard.pas(3145) Hint: H2443 Inline function 'SmallPointToPoint' has not been expanded because unit 'Types' is not specified in USES list

DelphiData.pas(477) Error: E2003 Undeclared identifier: 'AnsiStartsText'

DelphiData.pas(522) Error: E2003 Undeclared identifier: 'AnsiStartsText'

Utils.pas(89) Fatal: F2063 Could not compile used unit 'DelphiData.pas'

** error 1 ** deleting Installer_nomo
Using d10 for build process.

Press ENTER to continue
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008581)
AHUser (developer)
2006-02-21 04:25

Is there an older jedi.inc somewhere on your disk where dcc32.exe finds it? If so this could be the problem for the hints and the error messages because in this case the COMPILER10 and all dependent defines are not defined like COMPILER6_UP, HAS_UNIT_TYPES.
(0008588)
denisfitz (reporter)
2006-02-21 08:28

Yes, that was it! Thanks!

- Issue History
Date Modified Username Field Change
2006-02-20 15:51 denisfitz New Issue
2006-02-21 04:25 AHUser Note Added: 0008581
2006-02-21 04:25 AHUser Status new => feedback
2006-02-21 08:28 denisfitz Note Added: 0008588
2006-02-21 09:26 AHUser Status feedback => resolved
2006-02-21 09:26 AHUser Resolution open => fixed
2006-02-21 09:26 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker