Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003527 [JEDI VCL] 00 JVCL Components major always 2006-02-20 20:07 2006-03-21 14:54
Reporter haerdalis View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003527: JvDock* seems to block system shutdown/logoff
Description Exact version: JVCL3.10 2006-02-04 build

Hello, I've come across a problem which looks like it's from your docking
components. I noticed this by somewhat a coincidence. You see, I had a program
made by myself open (which uses those comps) and selected the normal Log off/Shutdown, and everything else closed, but not that one.

I've somewhat tracked it down to the JvDock* compos by first copying the entire
form to another project, then removing the components from each provider.

When I removed either the JvDockServer or JvDockVID(VC) then the logoff as worked as expected, but not with them added and connected.

The same is true for most of the styles.

To me it looks like something is responding with a FALSE to WM_QUERYENDSESSION,
but not explicitly (had been easy to track then).

To make sure it wasn't my own code which did this I handled that message directly from all forms (and those did return what was expected).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008712)
remkobonte (developer)
2006-03-21 14:54

This is now fixed in Rev 1.16 of JvDockSupportProc.pas:

A window constructed with AllocateHWnd did NOT call DefWindowProc so the WM_QUERYENDSESSION was unprocessed.

- Issue History
Date Modified Username Field Change
2006-02-20 20:07 haerdalis New Issue
2006-03-21 14:54 remkobonte Status new => resolved
2006-03-21 14:54 remkobonte Fixed in Version => 3.20
2006-03-21 14:54 remkobonte Resolution open => fixed
2006-03-21 14:54 remkobonte Assigned To => remkobonte
2006-03-21 14:54 remkobonte Note Added: 0008712


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker