Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003550 [JEDI VCL] 00 JVCL Components major always 2006-03-02 20:37 2006-04-07 07:23
Reporter wzhuang View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003550: TJvScheduledEvents can't save by TJvAppRegistryStorage/TJvAppIniFileStorage/TJvAppDBStorage
Description as set the AppStorage, AppStoragePath, then set AutoSave = True,
TJvScheduledEvents always show the message:
'Exception EAccessViolation in module Project1.exe at xxxx',
and nothing is saved or loaded.

or is there a document said how to save it? there is none
about it in the Help.
Additional Information
Tags No tags attached.
Attached Files zip file icon example.zip [^] (422,085 bytes) 2006-03-03 08:41

- Relationships

-  Notes
(0008625)
jfudickar (developer)
2006-03-03 03:36

Could you create a sample for this?
(0008626)
wzhuang (reporter)
2006-03-03 08:44

I upload one very simple example for this. there is a event under JvScheduledEvents1. even non-event, it still raise 'EAccessViolation'.
(0008677)
jfudickar (developer)
2006-03-16 15:10

I've posted a new version of the JvScheduledEvents.pas to cvs. Now the AccessViolation didn't raise.

The problem was, that the appstorage components are destroyed, before the ScheduledEvents, and the AutoSave is fired inside the destroy.

Now there is no AccessViolation, but in your sample the save already didn't work. I would say, that you have to do the save manually in the onformclose, or you have to destroy the Events BEFORE the appstorage.

Greetings
Jens
(0009026)
obones (administrator)
2006-04-07 07:23

This is then resolved.

- Issue History
Date Modified Username Field Change
2006-03-02 20:37 wzhuang New Issue
2006-03-03 03:36 jfudickar Note Added: 0008625
2006-03-03 08:41 wzhuang File Added: example.zip
2006-03-03 08:44 wzhuang Note Added: 0008626
2006-03-16 15:10 jfudickar Note Added: 0008677
2006-03-16 15:10 jfudickar Assigned To => jfudickar
2006-03-16 15:10 jfudickar Status new => feedback
2006-04-07 07:23 obones Status feedback => resolved
2006-04-07 07:23 obones Resolution open => fixed
2006-04-07 07:23 obones Note Added: 0009026


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker