Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003558 [JEDI VCL] 00 JVCL Components major always 2006-03-05 17:00 2006-04-29 07:14
Reporter Pavel Vozenilek View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003558: Missing entry point in 3.20 JvCoreC6R.bpl prevents loading by BCB IDE
Description BCB Enterprise 6.4 (+speed fix by Andreas Hausladen)

3.10 (complete: JCL + JVCL) installed and populated palette OK (with exception of several packages) and worked.

3.20 (complete: JCL + JVCL) compiles OK but when BCB IDE starts I get error: entrypoint

@Jvcomponent@TJvForm@CreateParams$qqrr22Controls@TCreateParams

not found in JvCoreC6R.bpl for most of the packages. The palette loads only few (~4) JEDI packages. Tried several times, always the same result.

After uninstall reinstalled 3.10 - compilation OK and with the few already mentioned exceptions the palette is populated.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008628)
Pavel Vozenilek (reporter)
2006-03-05 17:04

Before I installed 3.20 the 3.10 was completely uninstalled, so I do not think the two versions got mixed.
(0008635)
AHUser (developer)
2006-03-09 16:50

> BCB Enterprise 6.4 (+speed fix by Andreas Hausladen)
Better use the term "bcc32pch" because I first had to think what "JVCL speed fix" I should have written. ;-)

The old mechanism for compiling BCB packages sometimes forgot to update some packages if you do not use the "Build packages" option in the installer. This changes with the newest version (CVS/daily snapshot, requires JCL CVS/daily snapshot) which is far superior to the old installer.
(0008637)
Pavel Vozenilek (reporter)
2006-03-09 17:05

The problem occured even when I checked the "build" option. I may try the CVS version however it would take some time as I need to reinstall the BCB completely and have heavily "customized" version.
(0009002)
obones (administrator)
2006-04-05 08:25

Any news?
(0009175)
Martin Kvoch (reporter)
2006-04-24 03:21
edited on: 2006-04-24 03:40

Hi,
I have the same problem with Delphi6 IDE during starting it.
Before this, I've performed the complete uninstalling of the old JCL and JVCL and install newest ones (i.e. APR-23-2006) with "Build packages" checked.

An example of error message:
The entry point of procedure @Jvcomponent@TJvForm@ShowModal$qqrv is not found in dynamically linked library JvCoreD6R.bpl

Please, help me.
Thank you.
Martin

(0009195)
Martin Kvoch (reporter)
2006-04-28 02:35

Reminder sent to: AHUser, obones

Hi,
may anybody have a look at issue#3558 ?
Thanks in advance
Martin
(0009196)
obones (administrator)
2006-04-28 02:45

Well, I told the original poster to use the latest CVS (now SVN) version or a daily zip (http://jvcl.sf.net/daily/) [^] and he has not reported back.
On top of this, it oes work at my place, and I seriously suspect you have leftover dcp/bpl/bpi/lib files from the previous JVCL installation.
So cleanup your setup, try with the latest daily zip and it will work
(0009200)
Martin Kvoch (reporter)
2006-04-29 01:49

Hello,
you was right!
After deinstallation, some of old debug bpls was "hidden" in $DELPHI\bin.

For now, all is OK. You may mark this issue resolved.
Thank you

Martin

- Issue History
Date Modified Username Field Change
2006-03-05 17:00 Pavel Vozenilek New Issue
2006-03-05 17:04 Pavel Vozenilek Note Added: 0008628
2006-03-09 16:50 AHUser Note Added: 0008635
2006-03-09 16:52 AHUser Status new => feedback
2006-03-09 17:05 Pavel Vozenilek Note Added: 0008637
2006-04-05 08:25 obones Note Added: 0009002
2006-04-24 03:21 Martin Kvoch Note Added: 0009175
2006-04-24 03:40 Martin Kvoch Note Edited: 0009175
2006-04-25 03:30 Martin Kvoch Issue Monitored: Martin Kvoch
2006-04-28 02:35 Martin Kvoch Issue Monitored: AHUser
2006-04-28 02:35 Martin Kvoch Issue Monitored: obones
2006-04-28 02:35 Martin Kvoch Note Added: 0009195
2006-04-28 02:45 obones Note Added: 0009196
2006-04-29 01:49 Martin Kvoch Note Added: 0009200
2006-04-29 01:50 Martin Kvoch Issue End Monitor: Martin Kvoch
2006-04-29 07:14 AHUser Status feedback => resolved
2006-04-29 07:14 AHUser Resolution open => fixed
2006-04-29 07:14 AHUser Assigned To => AHUser
2007-12-16 11:20 AHUser Issue End Monitor: AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker