Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003565 [JEDI VCL] 00 JVCL Components minor always 2006-03-08 03:53 2006-03-10 03:24
Reporter ykami View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003565: JvMainMenu - Problem of width measurement(in Japanese locale)
Description The width of MenuItem shortens more than necessary length
 in a Japanese locale(SysLocale.FarEast = true).
(Only msOwnerDraw style is correct.)

JvMenus.pas Revision: 1.85

It is because the description of Hotkey in Japanese locale is different.

*MenuItem's Caption Property
normal style: &File
Japanese style: File(&F)
(The part of "File" is actually multibyte character.)

*Return Value of StripHotkey().

normal style: File
Japanese style: File

But,The string that should be displayed is as follows.

normal style: File
Japanese style: File(F)
Additional Information
Tags No tags attached.
Attached Files zip file icon JvMenu_jp_locale_problem.zip [^] (9,415 bytes) 2006-03-08 03:53

- Relationships

-  Notes
(0008648)
AHUser (developer)
2006-03-10 03:24

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2006-03-08 03:53 ykami New Issue
2006-03-08 03:53 ykami File Added: JvMenu_jp_locale_problem.zip
2006-03-10 03:24 AHUser Status new => resolved
2006-03-10 03:24 AHUser Resolution open => fixed
2006-03-10 03:24 AHUser Assigned To => AHUser
2006-03-10 03:24 AHUser Note Added: 0008648


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker