Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003568 [JEDI VCL] 00 JVCL Components feature always 2006-03-09 02:16 2006-06-27 07:01
Reporter ZENsan View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003568: Use "gettext" feature to JvDBGrid***Export components...
Description If Table/Query field uses OnGetText event and the values in DBGrid are displayed in some other format, Export ignores this - it's ok, verry good. But sometimes it is verry comfort to export what you see, but not 1 or 0 in place of Yes, No.
Additional Information
Tags No tags attached.
Attached Files ? file icon JvDBGridExport.pas [^] (38,003 bytes) 2006-04-21 12:11

- Relationships

-  Notes
(0008783)
marcgeldon (reporter)
2006-03-31 05:06

Maybe it's possible to add a property to the export component. And if this property (for example we call it "UseOnGetText" is "true", then we use the result from "OnGetText".

Was it just a feature idea from you or do you have the time to create a first possible version?
(0008812)
ZENsan (reporter)
2006-04-02 03:26

This is feature idea, but I also can create first possible version...
But if I do, then where must I send source files?
(0009082)
obones (administrator)
2006-04-13 02:49

Put the source files here, as a zip file.
Ideally, a diff file is the best (diff -u 3)
(0009153)
ZENsan (reporter)
2006-04-20 08:52

Here you are. I modified source a little bit. Now it checks if exists OnGettext handler for Field, then calls it and gets value for export. All Word, Excel, HTML,CSV and XML components updated.

Zigmund Bulinsh
(0009154)
ZENsan (reporter)
2006-04-20 09:07

Here is a more recent version...I added property UseFieldGetText for customizing export (when use and when do not use OnGetText event)
(0009155)
jfudickar (developer)
2006-04-20 09:28

Can't see any files ?
(0009169)
ZENsan (reporter)
2006-04-21 12:12

Something was wrong and my file was not uploaded. Now I see it. Hope you too.
(0009347)
ZENsan (reporter)
2006-05-24 05:28

So what happened? Why no comments? Why new feature not added jet?
(0009356)
AHUser (developer)
2006-05-27 07:09

> So what happened? Why no comments?
> Why new feature not added jet?

Because we are not fulltime JVCL developers.
(0009682)
obones (administrator)
2006-06-27 07:01

This is now in SVN. Next time, PLEASE respect the style guide, and DO NOT copy and paste the same function everytime. Was it that hard to create a GetFieldValue function in the ancestor?

- Issue History
Date Modified Username Field Change
2006-03-09 02:16 ZENsan New Issue
2006-03-31 05:06 marcgeldon Note Added: 0008783
2006-04-02 03:26 ZENsan Note Added: 0008812
2006-04-13 02:49 obones Note Added: 0009082
2006-04-13 02:49 obones Status new => feedback
2006-04-20 08:52 ZENsan Note Added: 0009153
2006-04-20 09:07 ZENsan Note Added: 0009154
2006-04-20 09:28 jfudickar Note Added: 0009155
2006-04-21 12:11 ZENsan File Added: JvDBGridExport.pas
2006-04-21 12:12 ZENsan Note Added: 0009169
2006-05-24 05:28 ZENsan Note Added: 0009347
2006-05-27 07:09 AHUser Note Added: 0009356
2006-06-27 07:01 obones Status feedback => resolved
2006-06-27 07:01 obones Fixed in Version => Daily / SVN
2006-06-27 07:01 obones Resolution open => fixed
2006-06-27 07:01 obones Assigned To => obones
2006-06-27 07:01 obones Note Added: 0009682


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker