Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003607 [JEDI VCL] 03 Donations feature always 2006-03-24 07:13 2006-04-14 04:30
Reporter joerg View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0003607: JVCL 3.20 JvEditor: New language "JScript" for syntax highlighter.
Description I added the script language "hlJScript" to
the list of syntax-higlighted languages.
Enum type "TJvHighlighter" has now one more entry.

JScript is Microsoft's variant of JavaScript/ECMAscript.
All those language are quite like Java, but have
very different reserved words.
Jscript is as popular as VBscript ... I wonder why it
was missing all the time? Maybe because everybody
thought it is too close to Java to be considered as an extra
language?

I modified 3 files from JVCL 3.20 download ... no big changes.
I took them from the "...\jvcl\run" directory.


Hope this helps ...

J. Hoppe
j_hoppe@t-online.de
Additional Information
Tags No tags attached.
Attached Files zip file icon jscript4jveditor.zip [^] (63,593 bytes) 2006-03-24 07:13

- Relationships

-  Notes
(0009106)
obones (administrator)
2006-04-14 04:30

Thanks, this is now in CVS.

- Issue History
Date Modified Username Field Change
2006-03-24 07:13 joerg New Issue
2006-03-24 07:13 joerg File Added: jscript4jveditor.zip
2006-04-07 04:10 obones Status new => acknowledged
2006-04-14 04:30 obones Status acknowledged => resolved
2006-04-14 04:30 obones Resolution open => fixed
2006-04-14 04:30 obones Assigned To => obones
2006-04-14 04:30 obones Note Added: 0009106


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker