Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003621 [JEDI VCL] 00 JVCL Components minor always 2006-04-04 04:44 2006-04-14 06:52
Reporter syk0 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0003621: TJvFilenameEdit - ASCII Characters
Description TJvFilenameEdit does not accept some ASCII characters from filenames.

i.e.
"C:\Program Files\My App\My App®.exe"
would return
"C:\Program Files\My App\My Appr.exe" in the edit field.

"®" returns "r"
"©" returns "c"

Therefore the resulting file name is incorrect.
Additional Information
Tags No tags attached.
Attached Files rar file icon JvFilenameEdit.rar [^] (510,978 bytes) 2006-04-05 14:50

- Relationships

-  Notes
(0008949)
obones (administrator)
2006-04-05 01:31

Please provide a sample application with such a filename, I'm very curious how you can even generate it.
(0009005)
syk0 (reporter)
2006-04-05 14:56

A sample application has been uploaded.

>"I'm very curious how you can even generate it."<
Just simply select a file rename it, use the ASCII code
"ALT + 0174" to get ®
or
"ALT + 0169" to get ©

These are characters wich can not be used in file names: "\ / : * ? < > |"

The problem is odd because JvEditbox will keep the ASCII characters.
(0009006)
remkobonte (developer)
2006-04-05 16:38

This happens because the control sets its property OEMConvert to True.

Work-around is to set it to false, but because the property is protected you have to cast it:

type
  TJvFilenameEditAccess = class(TJvFilenameEdit);
[..]
begin
  TJvFilenameEditAccess(JvFilenameEdit1).OEMConvert := False;
end;
(0009113)
obones (administrator)
2006-04-14 06:52

OEMConvert is now published, that will do to me.

- Issue History
Date Modified Username Field Change
2006-04-04 04:44 syk0 New Issue
2006-04-05 01:31 obones Note Added: 0008949
2006-04-05 01:31 obones Status new => feedback
2006-04-05 14:29 syk0 Issue Monitored: syk0
2006-04-05 14:50 syk0 File Added: JvFilenameEdit.rar
2006-04-05 14:51 syk0 Issue End Monitor: syk0
2006-04-05 14:56 syk0 Note Added: 0009005
2006-04-05 16:38 remkobonte Note Added: 0009006
2006-04-14 06:52 obones Status feedback => resolved
2006-04-14 06:52 obones Resolution open => fixed
2006-04-14 06:52 obones Assigned To => obones
2006-04-14 06:52 obones Note Added: 0009113


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker