Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003637 [JEDI VCL] 00 JVCL Components crash always 2006-04-12 08:17 2006-07-29 08:01
Reporter Maudrid View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003637: JvPluginManager Crashes on destroy
Description JvPluginManager Crashes or hangs the appliaction when "Build with runtime packages" is selected.
And before you ask; yes, I have "sharamem" as the first item in the uses clause of the project.
Additional Information
Tags No tags attached.
Attached Files zip file icon ProblemSource.zip [^] (3,656 bytes) 2006-04-12 08:17

- Relationships

-  Notes
(0009090)
obones (administrator)
2006-04-13 08:13

I'm seing this as well, but all three projects MUST be compiled with runtime packages.
(0009490)
obones (administrator)
2006-06-08 07:56

You have to set the PluginKind property to plgPackage for it not to crash. This is logical as the plugins are packages.
(0009512)
Maudrid (reporter)
2006-06-09 02:02

Your solution does not work.
Setting the PluginKind to plgPackage results in the application not load any of the plugins. Since they are old style DLLs and not packages.
Did you even try this or look at the source I provided? Look at the plugin count after you click the button. If you set it to plgDLL, the plugin count is 2. If you set it to plgPackage, it shows 0. I'm very sure that these plugins are not packages, since I selected DLL when I created them.
(0009555)
obones (administrator)
2006-06-09 08:38

But if you build with runtime packages, I suspect your plugins MUST be built with runtime packages as well. i'll double check, but I think it's that.
(0009708)
obones (administrator)
2006-06-28 02:49

Well, I removed "sharemem" from the list of uses for ALL projects and it works just fine. I think there is no need for sharemem to be used, and to me it IS the source of the problem.
(0009911)
obones (administrator)
2006-07-29 08:01

No reactions, I'm assuming this is fixed in the latest daily/svn

- Issue History
Date Modified Username Field Change
2006-04-12 08:17 Maudrid New Issue
2006-04-12 08:17 Maudrid File Added: ProblemSource.zip
2006-04-12 08:34 Maudrid Issue Monitored: Maudrid
2006-04-13 08:13 obones Note Added: 0009090
2006-04-13 08:13 obones Status new => confirmed
2006-06-08 07:56 obones Status confirmed => resolved
2006-06-08 07:56 obones Resolution open => no change required
2006-06-08 07:56 obones Assigned To => obones
2006-06-08 07:56 obones Note Added: 0009490
2006-06-09 02:02 Maudrid Status resolved => feedback
2006-06-09 02:02 Maudrid Resolution no change required => reopened
2006-06-09 02:02 Maudrid Note Added: 0009512
2006-06-09 08:38 obones Note Added: 0009555
2006-06-28 02:49 obones Note Added: 0009708
2006-07-29 08:01 obones Status feedback => resolved
2006-07-29 08:01 obones Fixed in Version => Daily / SVN
2006-07-29 08:01 obones Resolution reopened => fixed
2006-07-29 08:01 obones Note Added: 0009911


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker