Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003643 [JEDI VCL] 00 JVCL Components feature always 2006-04-17 07:55 2006-04-19 05:26
Reporter cornievs View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003643: TJvCustomImageButton, request to change "DrawButtonText" and "CalcButtonParts" to virtual
Description Is it possible to change the declaration of the above procedures/methods to virtual. I define my own class "TISButton" from it, to enable me to show multiple text lines on the button and I need to override these methods . The "default" does allow wordwrap if an icon is displayed. Anyway the default wordwrap does not works for me, as I have to control where the lines breaks occur. (I use the ~ character for this).

Additional Information In the attach file, I manaul change the declaration of the methods in TJvCustomImageButton to virtual.
Tags No tags attached.
Attached Files ? file icon ISButton.pas [^] (3,769 bytes) 2006-04-17 07:55

- Relationships

-  Notes
(0009127)
cornievs (reporter)
2006-04-17 08:00

Sorry the line 'The "Default" does allow wordwrap ..' must read 'The "Default" does NOT allow ...'
(0009141)
obones (administrator)
2006-04-19 05:26

This is now changed in SVN

- Issue History
Date Modified Username Field Change
2006-04-17 07:55 cornievs New Issue
2006-04-17 07:55 cornievs File Added: ISButton.pas
2006-04-17 07:58 cornievs Issue Monitored: cornievs
2006-04-17 08:00 cornievs Note Added: 0009127
2006-04-19 05:26 obones Status new => resolved
2006-04-19 05:26 obones Resolution open => fixed
2006-04-19 05:26 obones Assigned To => obones
2006-04-19 05:26 obones Note Added: 0009141


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker