Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003684 [JEDI VCL] 00 JVCL Components trivial always 2006-05-04 00:05 2006-05-04 00:08
Reporter ivan_ra View Status public  
Assigned To ivan_ra
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003684: JvCustomAppIniStorage raises error wnen reads empty value
Description The cause of problem is this code:

function TJvCustomAppIniStorage.RestoreLeadingTrailingBlanks(const Value: string): string;
begin
  if (Value[1] = '"') and (Value[Length(Value)] = '"') then
    Result := Copy(Value, 2, Length(Value) - 2)
  else
    Result := Value;
end;

It must simple check "Value" for empty string
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009251)
ivan_ra (developer)
2006-05-04 00:08

Now in SVN

- Issue History
Date Modified Username Field Change
2006-05-04 00:05 ivan_ra New Issue
2006-05-04 00:08 ivan_ra Status new => resolved
2006-05-04 00:08 ivan_ra Resolution open => fixed
2006-05-04 00:08 ivan_ra Assigned To => ivan_ra
2006-05-04 00:08 ivan_ra Note Added: 0009251


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker