Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003685 [JEDI VCL] 00 JVCL Components minor always 2006-05-05 07:47 2006-06-10 05:03
Reporter Salvatore Besso View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003685: Impossible to change the Title and Subtitle font of TJvWizard pages
Description As per title, if I try to change the font of the title or subtitle of TJvWizard's pages (all page types) after clicking on the OK button in the font dialog and inspecting the font property, it hasn't changed. I haven't included any test case because it's not necessary. Simply drop a TJvWizard on a form and create a couple of empty pages. Then try to change the Title and Subtitle font. That's all.
Additional Information
Tags No tags attached.
Attached Files zip file icon TestCase.zip [^] (56,133 bytes) 2006-05-10 02:30
zip file icon testcase2.zip [^] (56,476 bytes) 2006-06-09 09:39

- Relationships

-  Notes
(0009255)
Salvatore Besso (reporter)
2006-05-05 07:48

I forgot to mention that this is related to version 3.30, daily snapshot 10580 of 03/05/2006.
(0009261)
obones (administrator)
2006-05-09 01:18

Well, I'm sorry, I did just what you said, and it is working just fine.
(0009265)
Salvatore Besso (reporter)
2006-05-10 02:31

hello Obones,

sorry for the delay. I have uploaded a test case taking the form directly from my project. I have cleaned it and you can try by yourself, simply follow the instructions on the main form.

Regards
(0009517)
obones (administrator)
2006-06-09 02:44

Well, I just did it and the property was Tahoma, changing the style worked just fine. All this under BDS2006. I'll try to test this under D6, but to me this works just fine.
(0009527)
Salvatore Besso (reporter)
2006-06-09 03:25

hello Olivier,

not the style, but the font. Try to change it from Tahoma to say, Arial, or Times New Roman or whatever. I assure you that here (BDS 2006 architect) any attempt to change the font (name) is vain, it reverts back to what it was before.
(0009546)
obones (administrator)
2006-06-09 06:12

Well, I just tried, Delphi 2006 Enterprise, Update 2, no problems whatsoever.
(0009558)
Salvatore Besso (reporter)
2006-06-09 09:46

hello Olivier,

would you mind to download the second test case (testcase2.zip)? The first one didn't reflect exactly the actual situation. Beware, it's not a project, only files, and since I have used a bit of form inheritance, please open the files in the IDE in this sequence:

1. FSBBaseForm.pas
2. FSBBaseFormWithHintBar.pas
3. FUpdateForm.pas

Then stay on FUpdateForm, click on the wizard welcome page and then in the object inspector expand the Title node and open its Font property so that you open the font dialog. The font is actually Arial and I cannot change it. Try to change it to something else, for example Tahoma and then click on the OK button to confirm the change. Now open the Font dialog again and the font should be Arial again. I assure you that here it is so :-(

I suspect something to do with form inheritance, but it's strange because the TJvWizard is NOT inherited.
(0009563)
obones (administrator)
2006-06-10 04:32

Aha, it's the change through the Dialog that does not work.
Expand the Font property, change its name, and that works just fine.
I'm looking into it right now.
(0009564)
obones (administrator)
2006-06-10 05:03

The problem came from the ParentFont property being True in the Header property.
Now, when you change the font, either through the dialog or the properties, its value will be set to False, thus allowing the change. This mimicks what is done with other ParentXXX properties.
This change is now in SVN.

- Issue History
Date Modified Username Field Change
2006-05-05 07:47 Salvatore Besso New Issue
2006-05-05 07:48 Salvatore Besso Note Added: 0009255
2006-05-09 01:18 obones Note Added: 0009261
2006-05-09 01:18 obones Status new => feedback
2006-05-10 02:30 Salvatore Besso File Added: TestCase.zip
2006-05-10 02:31 Salvatore Besso Note Added: 0009265
2006-06-09 02:44 obones Note Added: 0009517
2006-06-09 03:25 Salvatore Besso Note Added: 0009527
2006-06-09 06:12 obones Note Added: 0009546
2006-06-09 09:39 Salvatore Besso File Added: testcase2.zip
2006-06-09 09:46 Salvatore Besso Note Added: 0009558
2006-06-10 04:32 obones Note Added: 0009563
2006-06-10 04:32 obones Status feedback => confirmed
2006-06-10 05:03 obones Status confirmed => resolved
2006-06-10 05:03 obones Resolution open => fixed
2006-06-10 05:03 obones Assigned To => obones
2006-06-10 05:03 obones Note Added: 0009564


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker