Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003692 [JEDI VCL] 00 JVCL Components minor always 2006-05-07 13:47 2006-06-09 02:18
Reporter boerema1 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003692: JvStringGrid.SortGridByCols doesn't sort more than 1000 rows
Description JvStringGrid.SortGridByCols doesn't completely sort more than 1000 rows because of this condition on line 1445 (revision 10436):

  until Sorted or (J = 1000);

Probably could be changed to

  until Sorted;
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009514)
obones (administrator)
2006-06-09 02:18

Well, I think it's a safeguard against never sorting grids. So I changed it to RowCount + 1000.

- Issue History
Date Modified Username Field Change
2006-05-07 13:47 boerema1 New Issue
2006-05-08 02:25 obones Status new => acknowledged
2006-06-09 02:18 obones Status acknowledged => resolved
2006-06-09 02:18 obones Resolution open => fixed
2006-06-09 02:18 obones Assigned To => obones
2006-06-09 02:18 obones Note Added: 0009514


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker