Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003696 [JEDI VCL] 00 JVCL Components minor always 2006-05-10 02:18 2006-05-10 03:50
Reporter robovideo View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003696: TJvHidDeviceController does not allow system restart/shutdown
Description By creating a new instance of TJvHidDeviceController all system shutdown/restart requests are cancelled because the code in EventPipe() does not return TRUE to WM_QUERYENDSESSION messages.
Additional Information Was working fine in older versions when Application.HookMainWindow(EventPipe) was used in place of actual AllocateHWnd(EventPipe). Actually verified in Delphi5.

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009266)
obones (administrator)
2006-05-10 02:56

Please use latest SVN version, this should have already been fixed:

http://jvcl.sf.net/daily/ [^]
(0009267)
robovideo (reporter)
2006-05-10 03:42

Verified. Working fine with latest version.

- Issue History
Date Modified Username Field Change
2006-05-10 02:18 robovideo New Issue
2006-05-10 02:19 robovideo Issue Monitored: robovideo
2006-05-10 02:56 obones Note Added: 0009266
2006-05-10 02:56 obones Status new => feedback
2006-05-10 03:42 robovideo Note Added: 0009267
2006-05-10 03:50 obones Status feedback => resolved
2006-05-10 03:50 obones Fixed in Version => Daily / SVN
2006-05-10 03:50 obones Resolution open => fixed
2006-05-10 03:50 obones Assigned To => obones
2006-05-10 03:50 obones Fixed in Version => Daily / SVN


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker