Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003706 [JEDI VCL] 00 JVCL Components major always 2006-05-15 20:37 2006-05-27 07:04
Reporter MStum View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003706: TJvRichEditToHtml is not formatting properly
Description I have a TJvRichEdit and a TJvRichEditToHtml. When i try to convert the RTF i pasted in Additional Information to HTML, the formating is partially wrong. See for example "Disc 1" where "Di" is bold and "sc 1" not. Or at the middle at "15. Cephalgy" where bold is lost or at the bottom at "14. Eisheillig" where the italic is lost halfway through.

I also used the latest JvRichEditToHtml.pas from SVN, but with that only the font size was fixed, the formatting is still broken.
Additional Information {\rtf1\ansi\ansicpg1252\deff0\deflang1031{\fonttbl{\f0\fnil\fcharset0 Tahoma;}}
\viewkind4\uc1\pard\b\f0\fs16 Compilation - Nachtschw\'e4rmer 7 (2004)\par
\b0\i Length: 135:59 - Discs: 2 - Total Rating: 0,0 / 5\par
\i0\par
Enter a review of the album itself here...\par
\par
\b Disc 1\par
\b0\i 1. Staubkind - Mein Herz (4:05) - Rating: 0 / 5\i0\par
\par
\par
\i 2. Schock - Immer Wieder (3:33) - Rating: 0 / 5\i0\par
\par
\par
\i 3. Soko Friedhof - Blutsauger (und Du Kommst...) (3:42) - Rating: 0 / 5\i0\par
\par
\par
\i 4. Cultus Feros - Wolfsballade (5:07) - Rating: 0 / 5\i0\par
\par
\par
\i 5. Qntal - Am Morgen Fruo (Bruno Krumm Rmx) (4:27) - Rating: 0 / 5\i0\par
\par
\par
\i 6. Potentia Animi - Herrscher (5:20) - Rating: 0 / 5\i0\par
\par
\par
\i 7. Letzte Instanz - Kopf Oder Zahl (3:03) - Rating: 0 / 5\i0\par
\par
\par
\i 8. Goethes Erben/Peter Heppner - Glasgarten (Traum Version) (6:17) - Rating: 0 / 5\i0\par
\par
\par
\i 9. ASP - Geisterjagd (Tr\'e4ne Im Meer) (4:22) - Rating: 0 / 5\i0\par
\par
\par
\i 10. Unheilig - Damien (6:20) - Rating: 0 / 5\i0\par
\par
\par
\i 11. Absurd Minds - Herzlos (Radio Edit) (4:47) - Rating: 0 / 5\i0\par
\par
\par
\i 12. Suicide Commando - Sterbehilfe (5:43) - Rating: 0 / 5\i0\par
\par
\par
\i 13. Snow in China - Gottes Tod (3:47) - Rating: 0 / 5\i0\par
\par
\par
\i 14. Mechanical Moth - Herz Aus Stein (5:50) - Rating: 0 / 5\i0\par
\par
\par
\i 15. Cephalgy - Weisses Fleisch (3:38) - Rating: 0 / 5\i0\par
\par
\par
\b Disc 2\par
\b0\i 1. Diorama - Das Meer (7:01) - Rating: 0 / 5\i0\par
\par
\par
\i 2. Rector Scanner - Spielzeug (4:41) - Rating: 0 / 5\i0\par
\par
\par
\i 3. Infekktion - Engel in Schwarz (RMX by ASP) (3:41) - Rating: 0 / 5\i0\par
\par
\par
\i 4. Umbra Et Imago - Sweet Gwendoline (Single Edit) (4:39) - Rating: 0 / 5\i0\par
\par
\par
\i 5. Saltatio Mortis - D\'e4dalus (4:10) - Rating: 0 / 5\i0\par
\par
\par
\i 6. Metallsp\'fcrhunde - Rattenf\'e4nger (4:17) - Rating: 0 / 5\i0\par
\par
\par
\i 7. Psycho Luna - Feenpfad (4:56) - Rating: 0 / 5\i0\par
\par
\par
\i 8. Mantus - St\'e4rker Als Der Tod (5:46) - Rating: 0 / 5\i0\par
\par
\par
\i 9. Mondglanz - Bruder Kain (4:04) - Rating: 0 / 5\i0\par
\par
\par
\i 10. Untoten - Rabenlied (2:29) - Rating: 0 / 5\i0\par
\par
\par
\i 11. Illuminate - Der Traum Des T\'e4nzers (Wei\'df) (5:16) - Rating: 0 / 5\i0\par
\par
\par
\i 12. Carved in Stone - Die G\'e4rten Der Feen (3:01) - Rating: 0 / 5\i0\par
\par
\par
\i 13. Staub - Brandung (3:47) - Rating: 0 / 5\i0\par
\par
\par
\i 14. Eisheillig - Tief Begraben (4:48) - Rating: 0 / 5\i0\par
\par
\par
\i 15. Elis - Abendlied (3:22) - Rating: 0 / 5\i0\par
\par
\par
\par
}
Tags No tags attached.
Attached Files htm file icon test.htm [^] (6,105 bytes) 2006-05-15 20:37
rtf file icon test.rtf [^] (2,745 bytes) 2006-05-15 20:39
? file icon RTF2HTMLTest.dpr [^] (196 bytes) 2006-05-24 17:00
? file icon Main.pas [^] (1,206 bytes) 2006-05-24 17:01
? file icon Main.dfm [^] (1,506 bytes) 2006-05-24 17:02
rtf file icon Rename_to_test.rtf [^] (4,102 bytes) 2006-05-24 17:04

- Relationships
related to 0002817resolvedobones RichEditToHTML does not translate accurately. 

-  Notes
(0009306)
MStum (reporter)
2006-05-15 20:40

I also added test.rtf, which is the output of
richExportMemo.PlainText := false;
richExportMemo.Lines.SaveToFile(edtExportTXTFilename.Text);

The RTF looks fine.
(0009307)
obones (administrator)
2006-05-16 00:52

Please try the latest version from SVN or from the daily site, as this has already been worked on, if I remember correctly.

http://jvcl.sf.net/daily/ [^]
(0009308)
MStum (reporter)
2006-05-16 03:23

I tried this as i mentioned. The attached test.htm is the output of the SVN-Version.
The difference between the SVN and the JVCL 3.20 version is that the SVN Version handles the fonts properly, but the formatting stays broken.
I will try to completely uninstall JVCL and reinstall a Version from SVN, but can someone try to convert the attached RTF to HTM with the most recent version?
(0009309)
MStum (reporter)
2006-05-16 03:48

I have just tried it with "jcl-2006-05-15" and "JVCL3-2006-05-16" using a simple function:
  JvRichEdit1.Lines.LoadFromFile('e:\test.rtf');
  JvRichEditToHtml1.ConvertToHtml(JvRichEdit1,'e:\test.htm');

Looks fine in the JvRichEdit, but the HTML Output is broken - it results in the attaches test.htm.
(0009348)
Jeff Cook (reporter)
2006-05-24 17:06

I have had the same experience - simple demo project uploaded.
(0009355)
AHUser (developer)
2006-05-27 07:02
edited on: 2006-05-27 07:03

I have rewritten the JvRichEditToHtml on last wednesday because I needed it in a project. So this bug is now fixed in SVN (today committed)


- Issue History
Date Modified Username Field Change
2006-05-15 20:37 MStum New Issue
2006-05-15 20:37 MStum File Added: test.htm
2006-05-15 20:39 MStum File Added: test.rtf
2006-05-15 20:40 MStum Note Added: 0009306
2006-05-15 20:49 MStum Issue Monitored: MStum
2006-05-16 00:52 obones Note Added: 0009307
2006-05-16 00:52 obones Status new => feedback
2006-05-16 00:52 obones Relationship added related to 0002817
2006-05-16 03:23 MStum Note Added: 0009308
2006-05-16 03:48 MStum Note Added: 0009309
2006-05-16 04:01 obones Status feedback => acknowledged
2006-05-24 16:55 Jeff Cook Issue Monitored: Jeff Cook
2006-05-24 17:00 Jeff Cook File Added: RTF2HTMLTest.dpr
2006-05-24 17:01 Jeff Cook File Added: Main.pas
2006-05-24 17:02 Jeff Cook File Added: Main.dfm
2006-05-24 17:04 Jeff Cook File Added: Rename_to_test.rtf
2006-05-24 17:06 Jeff Cook Note Added: 0009348
2006-05-27 07:02 AHUser Status acknowledged => resolved
2006-05-27 07:02 AHUser Resolution open => fixed
2006-05-27 07:02 AHUser Assigned To => AHUser
2006-05-27 07:02 AHUser Note Added: 0009355
2006-05-27 07:03 AHUser Status resolved => feedback
2006-05-27 07:03 AHUser Resolution fixed => reopened
2006-05-27 07:03 AHUser Note Edited: 0009355
2006-05-27 07:04 AHUser Status feedback => resolved
2006-05-27 07:04 AHUser Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker