Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003715 [JEDI VCL] 00 JVCL Components major always 2006-05-20 09:40 2006-06-09 03:10
Reporter rickwhisper2 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003715: JvThumbViews keeps directory open
Description JvThumbViews does not release the directory even if I change the directory entry.

For example, if I set the directory property to 'c:\testdir', and then change it to 'c:\newdir', the original 'c:\testdir' is still marked as in use and I cannot change the name of that directory (Access Denied error).

Additional Information This is a major issue since I have a panel showing images used in a particular directory. I then want to restore data from a backup, and the first thing I do is to rename the original directory (of which the image directory is a subdirectory of the one I want to rename). I tried changing the JvThumbViews to different directories before the rename, and even set it to an empty name, i.e. '', but unless I never set that directory to a subdirectory of the one I want to rename, I cannot do the rename.

It looks like perhaps the FindClose might not always get called within the GetFiles routine (the FindFirst is paired with another conditional which could prevent the FindClose from being executed).

I've compared this version with the latest 3.20 version, and see no source code changes, so I suspect the bug is still there.
Tags No tags attached.
Attached Files zip file icon ThumbViewBugDemo.zip [^] (330,255 bytes) 2006-05-23 10:22
? file icon JvThumbViews.pas [^] (35,082 bytes) 2006-05-23 10:48

- Relationships

-  Notes
(0009327)
obones (administrator)
2006-05-20 11:08

Can you attach the zipped sources of a sample application showing this problem?
Thanks.
(0009344)
rickwhisper2 (reporter)
2006-05-23 10:47

I've included a revised TJvThumbViews.pas that appears to correct the problem (corrected the FindClose issue).
(0009525)
obones (administrator)
2006-06-09 03:10

This is now in SVN.

- Issue History
Date Modified Username Field Change
2006-05-20 09:40 rickwhisper2 New Issue
2006-05-20 11:08 obones Note Added: 0009327
2006-05-20 11:08 obones Status new => feedback
2006-05-23 10:22 rickwhisper2 File Added: ThumbViewBugDemo.zip
2006-05-23 10:47 rickwhisper2 Note Added: 0009344
2006-05-23 10:48 rickwhisper2 File Added: JvThumbViews.pas
2006-06-09 03:10 obones Status feedback => resolved
2006-06-09 03:10 obones Resolution open => fixed
2006-06-09 03:10 obones Assigned To => obones
2006-06-09 03:10 obones Note Added: 0009525


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker