Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003716 [JEDI VCL] 00 JVCL Components crash always 2006-05-21 13:34 2006-05-26 08:43
Reporter elahn View Status public  
Assigned To elahn
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003716: TJvSpellChecker has a major memory leak
Description If I run the JvSpellCheckerDemo with FastMM and then close it without doing anything, it sits there for an extremely long period of time generating the leak report - I don't know how long 'cause I've not waited for it to finish.

By commenting out lines 340 & 353 in JvSpellChecker.pas, it removes the memory leak. i.e. in TJvDefaultSpellChecker.BuildTables, the lines: StrAddRef(Value);

The problem is apparently that the strings for the words aren't being disposed of correctly. Since this isn't my area of expertise, I'll leave it to someone else to fix.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009336)
remkobonte (developer)
2006-05-22 11:45

I've made a small change (Revision 10617). Please check if that fixes the problem.
(0009353)
elahn (developer)
2006-05-26 08:43

That fixed it, thanks. :)

- Issue History
Date Modified Username Field Change
2006-05-21 13:34 elahn New Issue
2006-05-22 11:45 remkobonte Note Added: 0009336
2006-05-22 11:45 remkobonte Status new => feedback
2006-05-26 08:43 elahn Status feedback => resolved
2006-05-26 08:43 elahn Fixed in Version => Daily / SVN
2006-05-26 08:43 elahn Resolution open => fixed
2006-05-26 08:43 elahn Assigned To => elahn
2006-05-26 08:43 elahn Note Added: 0009353


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker