Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003721 [JEDI VCL] 00 JVCL Components minor always 2006-05-22 14:12 2006-06-11 04:20
Reporter Karlheinz View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003721: Problem with TJvImage Property Transparent
Description I changed from TImage to TJvImage and did nothing else in my application.
I have one TJvImage at my form. I load a picture at runtime into the property picture. If transparent is set to true inside the objectinspector nothing will happen. The image is NOT transparent. In TImage the image IS transparent.
If I set transparent to true after loading of the picture the picture is transparent in TJvImage.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009337)
Karlheinz (reporter)
2006-05-22 14:22

With this combination it is working.
You need the switch from false to true otherwise the picture is not transparent.

  WTOImage.Transparent := false;
  WTOImage.Picture := DM_SKraft_F.ImageWTOLogo.Picture;
  WTOImage.Transparent := true;
(0009523)
obones (administrator)
2006-06-09 03:05

I don't see any reasons why this would happen, TJvImage is a mere wrapper around TImage. And on top of that, I think it is much better to always set Transparent AFTER the image has been loaded. What do you think?
(0009567)
Karlheinz (reporter)
2006-06-10 06:41

The problem is that you need the switch from Transparent=false to Transparent=true to get the transparent picture.

If you have set transparent to true inside of the objectinspector and your source looks like

WTOImage.Picture := DM_SKraft_F.ImageWTOLogo.Picture;
WTOImage.Transparent := true;

the picture is NOT transparent and that is different to the behavior of TImage.
(0009571)
obones (administrator)
2006-06-11 02:38

I'm seing this as well, but don't understand why yet.
(0009572)
obones (administrator)
2006-06-11 04:20

This is now fixed in SVN.

- Issue History
Date Modified Username Field Change
2006-05-22 14:12 Karlheinz New Issue
2006-05-22 14:22 Karlheinz Note Added: 0009337
2006-06-09 03:05 obones Note Added: 0009523
2006-06-09 03:05 obones Status new => feedback
2006-06-10 06:41 Karlheinz Note Added: 0009567
2006-06-11 02:38 obones Note Added: 0009571
2006-06-11 02:38 obones Status feedback => confirmed
2006-06-11 04:20 obones Status confirmed => resolved
2006-06-11 04:20 obones Resolution open => fixed
2006-06-11 04:20 obones Assigned To => obones
2006-06-11 04:20 obones Note Added: 0009572


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker