Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003731 [JEDI VCL] 00 JVCL Components major always 2006-05-28 16:15 2006-05-30 13:58
Reporter Jeff Cook View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003731: TJvRichEditToHtml still not formatting correctly
Description TJvRichEditToHtml was reported in Issue 0003706 to generate partially incorrect HTML.

I updoaded a demo project on issue 0003706. Using the same project, the HTML generated from the version downloaded from SVN today:-

// $Id: JvRichEditToHtml.pas 10621 2006-05-27 08:53:30Z ahuser $

is also incorrect - in fact it seems to be much worse.

In addition, AV's now occur in the System.pas unit when running in the IDE (Delphi 6) on the first call of JvRichEditToHtml - second and subsequent calls there is no AV.

Also when running the .exe outside the IDE I have once received an error message "External error 000080" - but I'm not sure of the "00080" as I didn't record it and it was not reproducible.

The generated HTML file seems to have non text characters and what might be a colour code e.g 000080 and 000000, in incorrect positions overwriting parts of valid HTML.
Additional Information I have uploaded the demo project with test input and output files.

P.S. I should have attached this to the issue 0003706 report but couldn't see how to do so - so have created another report.
Tags No tags attached.
Attached Files zip file icon RTF2HTML.zip [^] (4,553 bytes) 2006-05-28 16:15

- Relationships

-  Notes
(0009364)
AHUser (developer)
2006-05-30 11:58

I use this function in production code and it works. But your test case shows that the function does not work with the default memory manager. FastMM4 has no problems with the code. So it's the "St := St + ch;" code that causes the default memory manager to get out of memory. I'll try to optimize this.
(0009365)
AHUser (developer)
2006-05-30 13:58

Fixed in SVN.
I have rewritten the function again. But this time you must also use the SVN version of the JCL, because I have introduces TStringBuilder in JclStrings which is now used by JvRichEditToHtml

- Issue History
Date Modified Username Field Change
2006-05-28 16:15 Jeff Cook New Issue
2006-05-28 16:15 Jeff Cook File Added: RTF2HTML.zip
2006-05-28 16:17 Jeff Cook Issue Monitored: Jeff Cook
2006-05-30 11:58 AHUser Note Added: 0009364
2006-05-30 13:58 AHUser Status new => resolved
2006-05-30 13:58 AHUser Resolution open => fixed
2006-05-30 13:58 AHUser Assigned To => AHUser
2006-05-30 13:58 AHUser Note Added: 0009365


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker