Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003750 [JEDI VCL] 00 JVCL Components minor always 2006-06-06 22:00 2006-06-10 05:48
Reporter mm View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003750: TJvValidators.Validate does not display error indicators
Description In the case of multiple errors, indicators of a TJvErrorIndicator component linked in a TJvValidators component don't appear after TJvValidators.Validate. With blinking on, no indicator appears at all. With blinking off, some (but not all) appear. The handling of the blinking thread object in the source code may be the source of the trouble.

Enclosing the TJvValidators.Validate call in ErrorIndicator.BeginUpdate and ErrorIndicator.EndUpdate calls works around the issue. Such a sequence is missing in the TJvValidators.Validate method.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009543)
obones (administrator)
2006-06-09 05:54

But BeginUpdate and EndUpdate are not part of the IJvErrorIndicator interface. Would it make sense to add them?
(0009561)
mm (reporter)
2006-06-09 20:19

compare IJvValidationSummary, there the methods are declared. and since SetError on itself stops a thread and starts a new one, i'd say it makes sense.

thanks for your attention.
(0009566)
obones (administrator)
2006-06-10 05:48

This should now be fixed in SVN.

- Issue History
Date Modified Username Field Change
2006-06-06 22:00 mm New Issue
2006-06-09 05:54 obones Note Added: 0009543
2006-06-09 05:54 obones Status new => feedback
2006-06-09 20:19 mm Note Added: 0009561
2006-06-10 05:48 obones Status feedback => resolved
2006-06-10 05:48 obones Resolution open => fixed
2006-06-10 05:48 obones Assigned To => obones
2006-06-10 05:48 obones Note Added: 0009566


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker