Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003784 [JEDI VCL] 00 JVCL Components minor always 2006-06-28 10:59 2006-08-30 07:37
Reporter Thomas View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003784: Glitch drawing bug in TjvTreeView
Description If you have a tree

item [+]
- item
- item [+]

...

And you use the keys to move between them.
The following happens after leaving a focused item.
The drawing code almost always leaves "|" 1 pixel
border to the right. I think it is some rect invalidation
/ clearing that does include the full node rect.

[this happens on updated:Windows XP + Delphi 2005]

...

What my fix does is it ensures that the
"mausurement" of a node is always the same.
Additional Information procedure TJvTreeView.InternalCustomDrawItem(Sender: TCustomTreeView;
  Node: TTreeNode; State: TCustomDrawState; var DefaultDraw: Boolean);

#### OLD CODE ####

  if (State = []) or (State = [cdsDefault]) or (State = [cdsSelected]) then
  begin
    Canvas.Font := TJvTreeNode(Node).Font;
    Canvas.Brush := TJvTreeNode(Node).Brush;
  end;

#### NEW CODE ####

  if (State = []) or (State = [cdsDefault]) or (State = [cdsSelected]) then
    begin
      Canvas.Font := TJvTreeNode(Node).Font;
      Canvas.Brush := TJvTreeNode(Node).Brush;
    end
  else
    begin
      Canvas.Font.Name := TJvTreeNode(Node).Font.Name;
      Canvas.Font.Size := TJvTreeNode(Node).Font.Size;
    end
  ;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009724)
obones (administrator)
2006-06-29 06:05

Please provide the zipped sources of an application showing this.
For the record, I don't think setting the font name and size is a good thing, especially because they can be set to a completely different value from the parent.
(0010040)
obones (administrator)
2006-08-30 07:37

No answers for about 2 months, I'm assuming this is fixed.
Should it not be the case, please create a new issue

- Issue History
Date Modified Username Field Change
2006-06-28 10:59 Thomas New Issue
2006-06-29 06:05 obones Note Added: 0009724
2006-06-29 06:05 obones Status new => feedback
2006-08-30 07:37 obones Status feedback => resolved
2006-08-30 07:37 obones Fixed in Version => Daily / SVN
2006-08-30 07:37 obones Resolution open => fixed
2006-08-30 07:37 obones Assigned To => obones
2006-08-30 07:37 obones Note Added: 0010040


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker