Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003798 [JEDI VCL] 00 JVCL Components crash always 2006-07-06 14:03 2007-01-04 03:19
Reporter alexptp View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003798: When you load SCV file using JvCsvDataSet1.LoadFromFile() you will get runtime error - "Field "..." found in file but not ..."
Description When you load SCV file using JvCsvDataSet1.LoadFromFile() you will get runtime error - "Field "..." found in file but not in field definition".
Error happens when you try to open second (!) CSV file with field structure different from first one. Somehow old field definition was carried over to open new file.
You can see the error when you use CsvDataDemo from Examples folder.
When you open first CSV file, all works fine, when you open second CSV file with diff structure you will see an error.
Additional Information I was able to fix the issue adding following code:

      FHeaderRow:=aCsvFieldDef;

After line # 2591 in file JvCsvData.pas.
Tags No tags attached.
Attached Files zip file icon files1.zip [^] (317,544 bytes) 2006-07-10 09:37

- Relationships

-  Notes
(0009777)
obones (administrator)
2006-07-07 02:26

Please provide the zipped sources of a sample application showing this "problem"
(0009781)
alexptp (reporter)
2006-07-10 09:37

I attached file:
- sample project
- 2 CSV test files
- Word doc with screenshots
(0010246)
obones (administrator)
2006-09-29 07:22

File has changed since then, please first test with the latest SVN version from http://jvcl.sf.net/daily/ [^]

If the problem is still there, please provide a bit more context around the line you changed so that I can find it in the current sources.
(0010513)
obones (administrator)
2007-01-04 03:18

No news, I'm assuming this is fixed in the latest revision

- Issue History
Date Modified Username Field Change
2006-07-06 14:03 alexptp New Issue
2006-07-07 02:26 obones Note Added: 0009777
2006-07-07 02:26 obones Status new => feedback
2006-07-10 09:37 alexptp File Added: files1.zip
2006-07-10 09:37 alexptp Note Added: 0009781
2006-09-29 07:22 obones Note Added: 0010246
2007-01-04 03:18 obones Status feedback => resolved
2007-01-04 03:18 obones Fixed in Version => Daily / SVN
2007-01-04 03:18 obones Resolution open => fixed
2007-01-04 03:18 obones Assigned To => obones
2007-01-04 03:18 obones Note Added: 0010513


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker