Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003804 [JEDI VCL] 00 JVCL Components minor always 2006-07-11 02:04 2006-09-29 06:31
Reporter dJabber View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003804: TJvTreeView : OnChanging event fires twice when AllowChange=false
Description OnChanging event fires twice when user
changes selected item by mouse and
AllowChange parameter in Onchanging handler is false
Additional Information I think this happens because in CN_NOTIFY(NM_CLICK, NM_RCLICK) handler in
TJvTreeView is assigned as following:

       Selected:=node

but it's default behavior - when user clicks or r_clicks on the treeview item,
the selection changes, so to we should "Return nonzero to prevent default processing" and after all custom processing we should assign

       Msg.Result:=1
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0010045)
obones (administrator)
2006-08-30 07:48

Please try with the latest version from SVN and provide the zipped sources of a sample application showing this.
(0010232)
obones (administrator)
2006-09-29 06:31

No news, assuming this is fixed.

- Issue History
Date Modified Username Field Change
2006-07-11 02:04 dJabber New Issue
2006-08-30 07:48 obones Note Added: 0010045
2006-08-30 07:48 obones Status new => feedback
2006-09-29 06:31 obones Status feedback => resolved
2006-09-29 06:31 obones Fixed in Version => Daily / SVN
2006-09-29 06:31 obones Resolution open => fixed
2006-09-29 06:31 obones Assigned To => obones
2006-09-29 06:31 obones Note Added: 0010232


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker