Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003820 [JEDI VCL] 00 JVCL Components minor always 2006-07-20 14:13 2006-07-21 01:34
Reporter GaryMugford View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003820: Jan's ArrayButton missing Enabled and Visible properties
Description The TjvArrayButton component lacks Enabled and Visible properties at the component level. It has come up that I would like to disable the button and having an Enabled property would be very beneficial. Since adding Enabled would be an opportune time to add the Visible property, you could solve two potential issues. In reporting this in the JEDI VCL forum, OBones asked if I wanted the properties to apply to the whole component, or to the individual buttons in the array (or both). MY need, which might be different than others', applies only to the full component. But I can see where others would like to see it apply to the individual buttons. At least as far as Enabled. I think the Visible property would be ill-advised, since it would change the dimensions of other buttons and could possibly lead to an assymetrical array.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009825)
obones (administrator)
2006-07-21 01:12

Enabled and Visible will be added at the component level.
A new Enableds property, indexed by button number will also added.
A property called Visibles, indexed by button number will NOT be added in the context of this issue as it would indeed lead to weird things in the component.
(0009827)
obones (administrator)
2006-07-21 01:34

All the indicated changes are now in SVN

- Issue History
Date Modified Username Field Change
2006-07-20 14:13 GaryMugford New Issue
2006-07-21 01:12 obones Note Added: 0009825
2006-07-21 01:12 obones Assigned To => obones
2006-07-21 01:12 obones Status new => confirmed
2006-07-21 01:34 obones Status confirmed => resolved
2006-07-21 01:34 obones Fixed in Version => Daily / SVN
2006-07-21 01:34 obones Resolution open => fixed
2006-07-21 01:34 obones Note Added: 0009827


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker