Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003837 [JEDI VCL] 00 JVCL Components trivial always 2006-07-26 03:58 2006-08-22 06:56
Reporter LiorF View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003837: JvInterpreter Length function is incorrect
Description Length function for arrays returns Length-1 instead of length.
Solution:
Add +1 in the relevant line.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009867)
obones (administrator)
2006-07-26 05:20

The relevant line being?
(0009869)
LiorF (reporter)
2006-07-26 07:07

unit :JvInterpreter_System
procedure JvInterpreter_Length
line: Value:=VarArrayHighBound(...
(0009885)
obones (administrator)
2006-07-29 07:14

Well, I'm sorry, but I ran this very simple script:

showmessage(inttostr(length('123')));

and it showed 3. To me this is definitely correct. You'll have to be a bit more specific and even give a sample program showing the issue.
(0009912)
LiorF (reporter)
2006-07-29 12:51

The problem is with variant arrays. Example:

var
  a:variant;
begin
  a:=VarArrayCreate([0,9],varDouble);
  Result:=Length(a);
end;

By the way, the reason I use variant arrays is because I can't get dynamic arrays fully working. Are they supposed to be fully implemented?
(0009997)
LiorF (reporter)
2006-08-22 06:06

Any progress? Was the bug fixed?
It's just adding '+1' in the line I pointed to.
(0009998)
obones (administrator)
2006-08-22 06:56

This is now fixed in SVN.
As to dynamic arrays, I have no ideas.

- Issue History
Date Modified Username Field Change
2006-07-26 03:58 LiorF New Issue
2006-07-26 05:20 obones Note Added: 0009867
2006-07-26 05:20 obones Status new => feedback
2006-07-26 07:07 LiorF Note Added: 0009869
2006-07-29 07:14 obones Note Added: 0009885
2006-07-29 12:51 LiorF Note Added: 0009912
2006-08-22 06:06 LiorF Note Added: 0009997
2006-08-22 06:56 obones Status feedback => resolved
2006-08-22 06:56 obones Fixed in Version => Daily / SVN
2006-08-22 06:56 obones Resolution open => fixed
2006-08-22 06:56 obones Assigned To => obones
2006-08-22 06:56 obones Note Added: 0009998


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker