Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003852 [JEDI VCL] 00 JVCL Components tweak always 2006-08-04 11:21 2006-08-28 08:45
Reporter ain View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003852: Allow to set TJvCaptionPanel caption's height
Description Currently TJvCaptionPanel uses GetSystemMetrics(SM_CYCAPTION) to get "caption rectangle" height (or width when CaptionPosition is either dpLeft or dpRight). This looks ugly on XP as the caption area is too tall. It would be nice if there were CaptionHeight property which user can set. When 0 (default) then GetSystemMetrics(SM_CYCAPTION) is used.
Additional Information
Tags No tags attached.
Attached Files ? file icon JvCPnl.bmp [^] (86,166 bytes) 2006-08-25 03:59

- Relationships

-  Notes
(0010002)
obones (administrator)
2006-08-22 07:26

CaptionHeight has been introduced in SVN
(0010025)
ain (reporter)
2006-08-25 03:57

It looks like there is a problem with the new CaptionHeight property - if I set it to 19 (which is value returned by GetSystemMetrics(SM_CYCAPTION) on my W2K) and then run prg on WinXP then there is an extra margin between panel's caption and client area. It looks like the space for caption area is reserved using result of GetSystemMetrics but painted using CaptionHeight... I'll try to attach an picture to show the problem.
(0010030)
ain (reporter)
2006-08-28 06:54

Now seems to work at runtime, but when seting CaptionHeight at design time then caption area isn't reallocated (same problem as the attached picture shows). Drop an CaptionPanel component on form and set CaptionHeight to 10 to see the problem.

And why FCaptionHeight field is defined inside JVCAPTIONPANEL_STD_BEHAVE conditional? It will cause problems when JVCAPTIONPANEL_STD_BEHAVE isn't defined as GetEffectiveCaptionHeight() isn't conditioanlly compiled.

Also, JvExtComponent unit is not needed in the uses clause.
(0010031)
obones (administrator)
2006-08-28 08:45

This is now fixed in SVN.
The declaration in IFDEF is a "refactoring" glitch
JvExtComponent IS required, remove it and you'll see

and finally please create NEW reports for NEW problems. Leave that one alone.

- Issue History
Date Modified Username Field Change
2006-08-04 11:21 ain New Issue
2006-08-22 07:26 obones Status new => resolved
2006-08-22 07:26 obones Fixed in Version => Daily / SVN
2006-08-22 07:26 obones Resolution open => fixed
2006-08-22 07:26 obones Assigned To => obones
2006-08-22 07:26 obones Note Added: 0010002
2006-08-25 03:57 ain Status resolved => feedback
2006-08-25 03:57 ain Resolution fixed => reopened
2006-08-25 03:57 ain Note Added: 0010025
2006-08-25 03:59 ain File Added: JvCPnl.bmp
2006-08-25 08:51 obones Status feedback => resolved
2006-08-25 08:51 obones Resolution reopened => fixed
2006-08-28 06:54 ain Status resolved => feedback
2006-08-28 06:54 ain Resolution fixed => reopened
2006-08-28 06:54 ain Note Added: 0010030
2006-08-28 08:45 obones Status feedback => resolved
2006-08-28 08:45 obones Resolution reopened => fixed
2006-08-28 08:45 obones Note Added: 0010031


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker