Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003862 [JEDI VCL] 00 JVCL Components feature always 2006-08-20 13:26 2006-08-24 05:37
Reporter marcgeldon View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003862: TJvMenu - Problems with check-menuitems
Description Please have a look at the demo application. All the item painters paint the check-menuitems very strange.

my file version of JvMenus.pas: 1.86
Additional Information
Tags No tags attached.
Attached Files zip file icon Test.zip [^] (3,927 bytes) 2006-08-20 13:26

- Relationships

-  Notes
(0009989)
obones (administrator)
2006-08-21 00:59

This is very weird...
(0009990)
obones (administrator)
2006-08-21 01:06

That's because you are not using any image and the ImageSize property of the TJvMainMenu is set to (0, 0)
Use images or set ImageSize to (16, 16) and you will get a valid drawing.
Now, do you consider I should add the checkmark width if there is no image, no glyph and ImageSize set to (0, 0) ?
(0010007)
marcgeldon (reporter)
2006-08-23 08:46

if there is no checkmark width, no glyph and the ImageSize is "0,0", I think this should be automatically set to "16,16". Otherwise it looks not very nice.
(0010015)
obones (administrator)
2006-08-24 05:37

This is now fixed in SVN
(0010016)
obones (administrator)
2006-08-24 05:37

This is now fixed in SVN
Note that ImageSize will not be changed, the fix works on internal calculations only.

- Issue History
Date Modified Username Field Change
2006-08-20 13:26 marcgeldon New Issue
2006-08-20 13:26 marcgeldon File Added: Test.zip
2006-08-21 00:59 obones Note Added: 0009989
2006-08-21 00:59 obones Assigned To => obones
2006-08-21 00:59 obones Status new => confirmed
2006-08-21 01:06 obones Note Added: 0009990
2006-08-21 01:06 obones Status confirmed => feedback
2006-08-23 08:46 marcgeldon Note Added: 0010007
2006-08-24 05:37 obones Status feedback => resolved
2006-08-24 05:37 obones Fixed in Version => Daily / SVN
2006-08-24 05:37 obones Resolution open => fixed
2006-08-24 05:37 obones Note Added: 0010015
2006-08-24 05:37 obones Note Added: 0010016


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker